Tech Support Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 · (Edited)
Hello
I have a problem with my entire laptop idle temperatures. i have a Legion Y540
SPECS:
RTX 2060
16 ( 2x8gb) DDR4 ram
i7 9750h
144hz monitor refresh rate

attached two screenshots , currently have just 2 tabs on opera opened ( this forum on each )
No idea what to do.
I have a cooler underneath (cheap plastic one) so the laptop isn't on even ground, there is nothing near it to block airflow or input hot/cold air and i don't have it wrapped up in a blanket or it sitting on my lap (of have i ever had it).
Looking forward to hearing suggestions on what to do
 

Attachments

·
Global Moderator
Electronic Design
Joined
·
52,024 Posts
Well, top suspects would be dust in the fan and channel. It could also be that the heatsink wasn't installed correctly and isn't really doing it's job, I ran into that once.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
I've worked in a pc repair shop, i've seen worse. issue with laptops tho, tight spaces.
My gpu starts at 50 degrees celsius after boot up which i believe is a lot for something that hasn't ran for 10 hours.
opening up the laptop today, hopefully im gonna get to the bottom of this issue..
 

·
TSF Moderator , Hardware Team , Networking Team
Joined
·
10,505 Posts

?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #13 ·

?
Sorry i don't understand what i am supposed to be looking at here

this is from gpu-z

Font Rectangle Material property Screenshot Communication Device
Rectangle Font Material property Screenshot Parallel
 

·
TSF Moderator , Hardware Team , Networking Team
Joined
·
10,505 Posts
"ok so i have taken the GPU apart and cleaned it completely and reapplied the thermal paste, i will give an update in a few minutes to see whats happening, but currently its starting on 40C and 44% fan speed, the temp went up to 48C after starting all my programs but so far so good "

"ok the complete cleaning seems to solving all my problems "
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #15 ·
OK, so i cleaned out the fans without removing the fans and having to apply more paste
Laptop is currently at 52celsius while idle and 56 with chrome open.
Currently it's 58 with a game running
Cleaning it out seems to have fixed EVERYTHING

Thank you for the suggestions :) Problem solved
 
1 - 19 of 19 Posts
Top