Tech Support Forum banner

Rome Total War Directx 9 problems

14220 Views 14 Replies 3 Participants Last post by  Rometotalwarfan
Can someone help me out here. when i start my new rome total war it says "Rome Total War failed to find Directx 9 which is required for the game to run. Please reinstall." I don't even know how to reinstall my directx 9. i ran dxdiag and it told me that i have directx 11. I dont know if that has to do with something but i am really confused and i just want to play my new game. i have tried what people have said on other websites and it just doesnt work. What happened was, it worked just fine 3 months ago, but i installed windows 7 again to wipe my computer because i had noticed it was running slow and i though by wiping it, the speed would increase. Now, when i have installed it and start to run. It says that message about my directx 9 :4-dontkno
Not open for further replies.
1 - 15 of 15 Posts
Hello and welcome to the forum, Rometotalwarfan :wave:

Download the latest directx 9.0c and see if it solves the issue.
Now i just installed the directx 9 link that you gave me and tried to run my game. It still says the message about the directx 9. Any other ideas?
Make sure you are running on the latest drivers. Make sure you uninstall the older drivers before installing the new ones.

Can we get your full system specs? Download System Spec and run it. Open it and go to 'file' and hit 'save to CSV'. Save the file to your desktop, and open it. Copy what is inside and paste it back here.
Windows: Microsoft Windows 7 Home Edition, Version 6.1.7600
Internet Explorer: 8.0.7600.16385
Memory (RAM): 767 MB
CPU Info: AMD Athlon(tm) Processor 2650e
CPU Speed: 1217.9 MHz
Sound Card: Speakers (High Definition Audio
Display Adapters: Standard VGA Graphics Adapter | RDPDD Chained DD | RDP Encoder Mirror Driver | RDP Reflector Display Driver
Monitors: 1x; Generic PnP Monitor |
Screen Resolution: 1024 X 768 - 16 bit
Network: Network Present
Network Adapters: Atheros AR5007EG Wireless Network Adapter | Marvell Yukon 88E8040 PCI-E Fast Ethernet Controller
CD / DVD Drives: D: SlimtypeDVD A DS8A2S
COM Ports: NOT Present
LPT Ports: NOT Present
Mouse: 2 Button Mouse Present
Hard Disks: C: 139.3GB
Hard Disks - Free: C: 78.7GB
USB Controllers: 6 host controllers.
Firewire (1394): Not Detected
PCMCIA (Laptops): Not Installed
Manufacturer: Phoenix Technologies LTD
Product Make: eMachines D620
AC Power Status: OnLine
BIOS Info: | |
Time Zone: Pacific Standard Time
Battery: High
Motherboard: eMachines eMachines D620
Modem: Not detected

Is that it?

A lot of people have told me to reinstall my directx 9, but i dont know how to. Any tips on how i can uninstall it and reinstall it.
See less See more
On the link that you had previously given me. I had done my driver up-to-date test and it had told me that i had 7 out of date drivers. My standard VGA Graphics adapter is (out of date) from 2006. Both of my network adapters are from 2009 (out of date.) My high definition audio devise (out of date) is from 2009. Otherwise everything else is fine.
What program? The program I gave you was system spec, whatever else you clicked was an ad on the page and I suggest removing it.

I don't trust programs in ads that update my driver. I would do them manually. You need a driver for your video card, you can get drivers for everything else just to be up to date but I wouldn't say it is related to the cause.

Your PC is pretty old, why suddenly go out a buy a copy of windows 7? You don't even have a gig of ram. You have 767 MB's(strange number) of ram. Windows 7 needs 1 GB for 32bit, and 2GB's for 64 bit.
Well i had over a 1 gig of ram when i installed windows 7. my memory is lower now because i recently installed RTW.
Installing RTW doesn't affect the amount of RAM you've got.

"Display Adapters: Standard VGA Graphics Adapter" - This means your computer is using the default VGA driver instead of the proper graphics driver for your card, and is related to the DirectX error.

Go to your motherboard manufacturer's website to dowload the latest chipset drivers (these include the graphics, audio and network drivers for your laptop). Install and reboot.
ok. thanks, but one more thing. I am trying to install RTW to my desktop and when it tell me to insert disk 2 i do it. Then it says the improper disk has been inserted. I went on My computer and it said Disk 2 but my installation wont continue. I have tried opening data3 which is the file located on disk two to see if the directx 9 that came with the installation is there so if my disk 2 is a bad disk. If that would be it then my directx 9 is from a defaulted disk 2
Link to emachines D620 drivers:

Select Notebook, D Series, D620 and Windows 7 Home (32 or 64 bit, whichever is appropriate) from the menus to list the correct drivers for your laptop. The drivers available include Audio, Camera, LAN, Touchpad, VGA (graphics), and Wireless LAN.

I'm not sure what the problem is with Disk 2. Are you using the original retail CDs or a backup copy?

Install the latest DirectX 9.0c (June'10) after updating your drivers:
Last thing. Should i install all of the driver listed or just a select amount of them. If i need to install a select amount. Which ones should i download?
Answering your previous question. For disk two i am using the original retail copy
Start with the VGA and audio, then reboot and install DX9.0c. Reboot again and try your game. You can leave the other drivers until after the problem is solved.
Thank You soo much. I am curently installing the VGA update version from the list and wil notify you if i need more help.
1 - 15 of 15 Posts
Not open for further replies.