Tech Support banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
I'm setting up remote desktop and am having some problems.

The host machine is my XP Pro desktop. I know that the router is configured correctly and that it says in remote desktop that my username has access.

No matter what, I can't connect to it from my laptop (Vista), and I tried getting a friend of mine to connect to it, and he couldn't.

Thanks in advance,
Mike
 

·
Registered
Joined
·
48 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #4
At the Remote Desktop Connection screen, it asks for the computer, and I enter the IP address of the home router. I had set up the router so the host computer is port forwarding at port 3389 so that I can connect to it wherever in the world. But I am just configuring it via my home network.

It's asks for my credentials, I enter them, press OK, and it gives me this message:

-------------------------------------------------------------------------------------------

Remote Desktop cannot verify the identity of the computer you want to connect to. This
problem can occur if:

1) The remote computer is running a version of Windows that is earlier than Windows Vista.
2) The remote computer is configured to support only the RDP security layer.

Contact your network administrator or the owner of the remote computer for assistance.

Do you want to connect anyway?

| Yes | | No |
-------------------------------------------------------------------------------------------

So I click Yes.

It brings up the full black window with the Windows login screen in it.

I enter in the user name and password, and I get this message:

"Unable to log you on because of an account restriction."
| ok |

And that's the end of that...
 

·
Registered
Joined
·
48 Posts
try this.

from http://www.cubido.at/Blog/tabid/176/EntryID/171/Default.aspx

Since Vista you get this annoying Remote Desktop Dialog when connecting to Windows 2000 and Windows 2003 machines:





Fortunately, there is a little registry-setting to avoid this dialog poping up:
Add a DWord registry entry “AuthenticationLevelOverride” with value 0 to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Terminal Server Client

That’s it!

failing that look at this http://support.microsoft.com/kb/303846

SYMPTOMS
When you try to connect to a Windows XP-based computer by using the Remote Desktop tool, you may receive the following error message:
Unable to log you on because of an account restriction.

Back to the top
CAUSE
This behavior can occur if the account you are using to connect with has a null (blank) password. You cannot establish Remote Desktop connections when you are using an account with a null password.

Back to the top
RESOLUTION
To work around this behavior so you can establish Remote Desktop connections, log on at the console of the computer, and then set a password for that user account so that it no longer has a null password.

Back to the top
STATUS
This behavior is by design.

Back to the top
MORE INFORMATION
You can disable blank password restrictions by using a policy. To locate and change this policy:
1. Click Start, point to Run, type gpedit.msc, and then click OK to start the Group Policy Editor.
2. Open Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Accounts: Limit local account use of blank passwords to console logon only.
3. Double-click Limit local account use of blank passwords to consol logon only.
4. Click Disabled, and then click OK.
5. Quit Group Policy Editor.
NOTE: By default, this policy is on (enabled).
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top