Tech Support Forum banner
1 - 1 of 1 Posts

· Registered
114 Posts
Discussion Starter · #1 ·
I posted this on another forum, without resolution, so I'm hopeful someone on here has some suggestions.

This is driving me a bit potty, so I hope there is a simple resolution.

I have a network server running Unraid.

It's been set up for years now, with multiple shares, and for the past 18 months or so I have mapped several of the shares to drives on my Windows 10 PC in such a way that there is unfettered read-only access to those shares (without login credentials) and separate read/write access to the same shares (requiring login credentials). The rest of the household just has read-only access to the shares. It was set up this way to provide ransomware protection so that an infection on any pc in the network did not risk hitting the server. In addition to having the shares mapped as drives, I also have the server mapped as a network location (read-only access not requiring credentials).

So, for example, my music share has been mapped with drive letter M: for read-write and drive letter X: for read-only; movies are L: (read-write) and W: (read-only) etc etc

This worked fine for a long time, then suddenly about 1 month ago I started to get the error "Unable to connect M: to '\\\Music' Microsoft Windows Network: Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again. The connection has not been restored"

As far as I could tell nothing has changed on Windows, and I was able to resolve the issue temporarily by disconnecting all the read/write shares and remapping them. However, after rebooting Windows, the next time I tried to access the read-write shares the problem recurred. I repeated the solution and again all was fine, until it wasn't after another reboot. After a few times repeating the process I decided to be more drastic, so I just disconnected all the read-only shares permanently, leaving just the read-write shares.

Again this appeared to resolve the issue, but again after reboot I am unable to access the shares. Clicking on one of the shares fires the u/n and p/w prompt as expected but then I get the same error message after entering my credentials. Subsequently, clicking any of the other shares gives me the error message: "The user name or password is incorrect..." even though I haven't been prompted to add them at that point. Disconnecting and remapping the drives, using the same credentials, once again resolves the issue

I know as soon as I reboot, though, the problem will reoccur.

I discovered that restarting the Workstation service resolves the issue until the next reboot so I have a current workaround, running a batch script on reboot. This is a PITA though so I'd love to find a solution

Can anyone help me find a solution to this annoying problem? Thanks in advance.

OS Version: Microsoft Windows 10 Home, 64 bit, Build 19044, Installed 20220116111241.000000+000
Processor: AMD FX(tm)-8150 Eight-Core Processor, AMD64 Family 21 Model 1 Stepping 2, CPU Count: 8
Total Physical RAM: 16 GB
Graphics Card: AMD Radeon HD 5700 Series
Hard Drives: C: 930 GB (687 GB Free); D: 695 GB (118 GB Free); G: 15 GB (5 GB Free); P: 931 GB (324 GB Free); R: 1863 GB (693 GB Free); S: 2099 GB (698 GB Free);
Motherboard: ASUSTeK Computer INC. M4A89GTD-PRO, ver Rev 1.xx, s/n 104044950001251
System: American Megatrends Inc., ver 070512 - 20120705, s/n System Serial Number
Antivirus: Windows Defender, Enabled and Updated
1 - 1 of 1 Posts