Tech Support Forum banner

Reboot and select proper boot device...

5750 Views 14 Replies 4 Participants Last post by  andrew.lvp
"Reboot and select proper boot device or put media in the boot device and press any key"

I added a new 500GB SATA HDD into my PC last night, and now it won't boot, and I'm getting the error quoted above.

My original system setup was with two IDE hard drives, a 80GB one with Windows XP home on, and another one set to slave with 200GB.

Since this problem has arrived, I've removed all the hard drives and inserted another old one (8GB IDE known to be working). So I've rebooted my system, and it still gets same error message.

I've checked all the IDE cables ( replacing them with known working ones from other machines ). I've checked the power supply by changing the cables to other ones ( it's a hyper pro performance modular PSU, less than a year old ).

I've checked all the jumpers.

I've gone into the BIOS and under the boot sequence there is no drives showing. only Floppy and DVD drive ( though there is a second CD Drive... but this shows up in the BIOS under the removable storage menu ). ( I'm sure the HDD drive shows up in here under boot sequence, but it's been years since I've been into my BIOS - have not had the need! )

There are no USB pen drives, any other hardware connected to the PC at the moment.

I've managed to boot my PC and work with it with a DVD bootable copy of linux (DSL). But the HDD does not show up under this.

I've also swapped my IDE cables from the motherboard round. In the fashion that my DVD drives IDE cables ( connection and cable must be working to use linux ) so I've used this IDE cable and connected that to the HDD and ive used the one from the HDD and connected that to the DVD drive. Still getting the original error message!

I'm really stuck - and I need my computer to do my Uni work on ( Im doing computer science, so this is pretty important to me as you can imagine )

System info if this helps..

RAM: 400DDR 1024MB
PSU: 720watt max output.

please please please help!! :sigh: :sigh: :sigh:
See less See more
Not open for further replies.
1 - 15 of 15 Posts
Check the BIOS and make sure you have the correct HDD booting first. (yes it is possible to set one of the other HDDs as the boot drive.) Basically it sound like the computer is trying to boot to one of the other HDDs and not your system drive.
I've taken all the HDDs out now and there is only one in there (the 8GB one). Under the BIOS settings the HDD does not show at all. And the only options under boot sequence are the floppy drive and the DVD drive. I think my DVD drive may be broken, do you think this may be a reason why it can't detect the HDDs?
I'm taking that out now and I'm going to just have the CD drive. But I dout that will work..
Nope even with another CD drive in, still same error... :sigh:
Check the jumper settings on the IDE drives. Make sure they are configured Master/Slave.

Just a point of clarity. Some of these boards (don't know this one specifically) have two options to worry about when you set the BIOS.

First, there is the Hard Drive Priority setting....Then, the Boot Order. They are two different things, but both need to show the same drive as the boot drive. Might just double check this one.

I would suggest that you go back to your old setup while you troubleshoot this and follow Crazijoe's recommendation that you have the boot drive as Master (jumper setting) and the extra drive as Slave, with the master on the end of the ribbon cable and the slave in the middle of the ribbon cable. PUt it on the primary IDE and then with that setup, it might be easier to find the problem. Leave the Sata out of the mix right now or just don't connect it.
See less See more
I've done both of the above (I'm actually an engineer at a computer shop). I have removed everything off the system that is not needed. The only thing in there now is a single IDE drive (yes set to master) and is on primary IDE on the mobo, and it is connected to the primary connector on the IDE ribbon wire. As well as a single DVD drive set to primary, on the primary connector on the ribbon wire, and set to secondary IDE on the mobo.

I have tested with working components both the HDD, the PSU and the DVD drives.

My only thought now is that the HDD controller on the mobo may have broken some how, but I do not have a PCI IDE controller to test that.

In the BIOS when going to 'boot select' menu there is only an option now for boot from floppy. There is no sign of the two DVD drive, and the IDE HDD is also not displayed.

The BIOS is set to auto detect both SATA and PATA drives. (I have even tried selecting just the PATA.. same problems come up.) i have also tried resetting the BIOS to default settings - still no HDD is displayed.

I've also noted that the CD\DVD rom drives no longer open... :eek: i have checked, double checked and triple checked all the power connectors.

When computer is turned on, the HDD LED is constantly turned on.
See less See more

Have you tried clearing the CMOS in case something in case there might be an error in the BIOS setup menu from an electrical surge, or even something not saved properly (not your fault) on a shutdown. I would at least give that a try if it was here in my shop, so since you work with computers, might be worth a shot.

Have you tried clearing the CMOS in case something in case there might be an error in the BIOS setup menu from an electrical surge, or even something not saved properly (not your fault) on a shutdown. I would at least give that a try if it was here in my shop, so since you work with computers, might be worth a shot.
Thank you for replys btw. Yea I think I've tried everything except that. And on start up when entering the BIOS I do get a single bleep followed by a double beep (I know that's a error message).

I've only been working at this computer shop for just about 6 months.. so I'm not exactly the most experience engineer. :rolleyes:

Just to clarify (i've only heard of this in theory, never actually done this, I've never had the need to!), clearing the CMOS involves moving the CMOS jumper pins on the mobo, and putting in reset pos for about 10 secs. But what happens then? Do I just reboot normally and go into BIOS and reset eveything? Should my HDDs now appear on the drive list?

Thanks again.

You can clear the CMOS two ways. First of all, unplug the thing and gound yourself. Then the first way is to move the little jumper from pins 1 & 2 to pins 2 & 3....then wait a couple of minutes and move it back to pins 1 & 2. Then take it for a test drive and see if it comes back up. I normally with that save the default settings and then let it reboot and see what happens.

The second method involves unplugging it, grounding yourself, and then removing the motherboard battery for a few minutes. Then, replace it the same way you took it out and fire it up or take it for a test drive.

Regarding the beep codes. I didn't know you were getting those beep codes, so if you will go HERE to this site, it will help you to know what that code means. That way we will know what you are looking for.

Regarding the hard drive question. We won't know if they will come up or not, because we at this point don't know what error we are dealing with. The beep codes should help us to know that.

Post back if you have questions/concerns.
See less See more
Hello again,

I've reset my BIOS, and I'm still having the same problems, the HDDs are simply not being detected. I think my problem may be that I've somehow blow my HDD detection module on the mobo. Do you think it would be possible to buy a PCI IDE controller and run my HDD off those?
just bought and tested the PCI IDE controller.. still doesnt work! :sigh:

Did you find out what the beep code was telling you??????? If so, what did it say?
If I'm not mistaken, I went to some menu to choose how system boots up the next time. I forgot what I typed into the "Run" command to get those options.
1 - 15 of 15 Posts
Not open for further replies.