Tech Support Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey everybody,

I tried to install the Service pack 1, it failed due to error code 0x800f0826.

I found out that that the Windows Modules Installer, which is required for the install, appearently isn't working.
It is not listed under Control Panel > Administration > Services.

I tried to fix it (sfc /scannow, TrustedInstaller reg fix) but that made no difference.

So i had some expert from microsoft telling me that i should re-register windows update dlls, but a ran into some problems there:


"The module 'wuaueng.dll' was loaded but the call to
DllRegisterServer failed with the error code 0x80070005."

-----------------------------

"The module "wuaueng1.dll" failed to load.

Make sure the binary is stored at the specified path or
debug to check for problems with the binary or
dependant .DLL files.

The specified module could not be found."

------------------------------

"The module 'atl.dll' was loaded but the call to
DllRegisterServer failed with the error code 0x8002801c."

------------------------------

"The module "wucltui.dll" failed to load.

Make sure the binary is stored at the specified path or
debug to check for problems with the binary or
dependant .DLL files.

The specified module could not be found."

------------------------------

"The module 'wups.dll' was loaded but the call to
DllRegisterServer failed with the error code 0x80070005."

------------------------------

"The module 'wups2.dll' was loaded but the call to
DllRegisterServer failed with the error code 0x80070005."

------------------------------

"The module "wuweb.dll" failed to load.

Make sure the binary is stored at the specified path or
debug to check for problems with the binary or
dependant .DLL files.

The specified module could not be found."

_____________________________________________

What would i do? Are the files corrupt? If they not are located, can i restore them in some way?
My computer isn't delivered with a Vista CD/DVD, so i can't run a Vista Repair.

Thanks in advance.
 

·
Microsoft MVP
Joined
·
3,339 Posts
Welcome to TSF!

0x80070005 is Access Denied
0x8002801c is Unable to access the Registry
Were you running the Regsvr32 commands from an Elevated Command Prompt? If run from a normal Command Prompt, you'll get those two errors.
Click Start, type cmd, when cmd.exe appears in the list, right click it and click Run as administrator

For the file not found, are you sure about the file names?
I don't see wuaueng1.dll on my Vista system.
And for these I found some that are close:
wucltui.dll -- wucltux.dll
wuweb.dll -- wuwebv.dll

I also have these two:
wuapi.dll
wudriver.dll
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
okay i tried to run elevated cmd and it helped with some of the files.
I did this:

net stop WuAuServ
The service Windows Update are stopping
The service Windows Update stopped

REGSVR32 WUAPI.DLL
REGSVR32 WUAUENG.DLL
REGSVR32 WUCLTUX.DLL
REGSVR32 WUDRIVER.DLL
REGSVR32 WUPS.DLL
REGSVR32 WUPS2.DLL
REGSVR32 WUWEBV.DLL
REGSVR32 ATL.DLL

net start WuAuServ
The service Windows Update are starting
The service Windows Update started

there is still one error though:

"The module "wudriver.dll" was loaded but the entry-point DllRegisterServer was not found.

Make sure that "wudriver.dll" is a valid DLL or OCX file and then try again."

after a reboot Windows Modules Installer still don't work. :mad:
Is there a way i can fix this? Should i replace the WUDRIVER.DLL file?

-joshua
 

·
Microsoft MVP
Joined
·
3,339 Posts
1 - 4 of 4 Posts
Status
Not open for further replies.
Top