Tech Support banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Our server is redhat version 8 (psyche). We use proftpd to put web pages, etc, on the server. On my PC, I did: Start, Run, command to open the screen, then changed to the diredtory the pictures are in that I want to send. Then I did ftp to the server, logged in and typed bin then changed the server to the taget directory. Then:

ftp> put nameofpic.gif
200 PORT command successful
150 Opening BINARY mode data connection for nameofpic.gif
226 Transfer complete
ftp: 1076 bytes sent in 0.06 seconds 17.93Kbytes/sec

Problem is, the pictures do not arrive. I telnet to the server and look in the target directory - not there. I need some clues as to where to look for those pictures or what might be broken. Thanks in advance for any help. Logs follow.

/var/log/messages shows:

Oct 10 10:10:34 midnight proftpd[14425]: midnight.chismtrail.com (216.107.115.12
2[216.107.115.122]) - FTP session opened.
Oct 10 10:13:25 midnight proftpd[14425]: midnight.chismtrail.com (216.107.115.12
2[216.107.115.122]) - FTP session closed.

/var/log/xferlog shows:

Mon Oct 10 10:12:25 2005 0 216.107.115.122 582 /usr/ginftp/var/www/ginftp/stormy
slightningllc.com/images/lightning.gif b _ i r ginftp ftp 0 * c
Mon Oct 10 10:12:53 2005 0 216.107.115.122 125 /usr/ginftp/var/www/ginftp/stormy
slightningllc.com/images/lightning3.gif b _ i r ginftp ftp 0 * c
Mon Oct 10 10:13:08 2005 0 216.107.115.122 1076 /usr/ginftp/var/www/ginftp/storm
yslightningllc.com/images/lightning3l.jpg b _ i r ginftp ftp 0 * c
Mon Oct 10 10:13:20 2005 0 216.107.115.122 1035 /usr/ginftp/var/www/ginftp/storm
yslightningllc.com/images/lightning3r.jpg b _ i r ginftp ftp 0 * c

/var/log/httpd/access_log for that time frame shows:

84.240.74.3 - - [10/Oct/2005:10:04:06 -0400] "GET / HTTP/1.1" 200 1968 "-" "MJ12
bot/v1.0.3 (http://majestic12.co.uk/bot.php?+)"
68.119.117.160 - - [10/Oct/2005:10:14:45 -0400] "GET / HTTP/1.1" 200 3562 "-" "M
ozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; {956656E2-84FB-A6B7-F0C3-D0B2D
F506642}; iebar; acc=marketingsector; .NET CLR 1.1.4322)"
68.119.117.160 - - [10/Oct/2005:10:14:46 -0400] "GET / HTTP/1.1" 200 3562 "-" "M
ozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; {956656E2-84FB-A6B7-F0C3-D0B2D
F506642}; iebar; acc=marketingsector; .NET CLR 1.1.4322)"

/var/log/httpd/error_log for that time frame shows:

[Mon Oct 10 09:52:47 2005] [error] [client 68.142.249.149] File does not exist:
/var/www/ginftp/heritageheatingandcooling.com/robots.txt
[Mon Oct 10 10:21:29 2005] [error] [client 216.107.115.122] File does not exist:
/var/www/ginftp/stormyslightningllc.com/favicon.ico
[Mon Oct 10 10:21:29 2005] [error] [client 216.107.115.122] File does not exist:
/var/www/ginftp/stormyslightningllc.com/images/lightning3ljpg.jpg, referer: htt
p://stormyslightningllc.com/
[Mon Oct 10 10:21:29 2005] [error] [client 216.107.115.122] File does not exist:
/var/www/ginftp/stormyslightningllc.com/images/lightning3r.jpg, referer: http:/
/stormyslightningllc.com/
[Mon Oct 10 10:21:29 2005] [error] [client 216.107.115.122] File does not exist:
/var/www/ginftp/stormyslightningllc.com/images/lightning.gif, referer: http://s
tormyslightningllc.com/
[Mon Oct 10 10:21:42 2005] [error] [client 216.107.115.122] File does not exist:
/var/www/ginftp/stormyslightningllc.com/images/lightning3ljpg.jpg, referer: htt
p://stormyslightningllc.com/
[Mon Oct 10 10:21:42 2005] [error] [client 216.107.115.122] File does not exist:
/var/www/ginftp/stormyslightningllc.com/images/lightning3r.jpg, referer: http:/
/stormyslightningllc.com/
[Mon Oct 10 10:21:42 2005] [error] [client 216.107.115.122] File does not exist:
/var/www/ginftp/stormyslightningllc.com/images/lightning.gif, referer: http://s
tormyslightningllc.com/
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
I originally posted this question to the Apache list, thinking my httpd was broken. They quickly told me it is the proftpd that's the problem and sent me here to ask. If this is not the correct place, please tell me where to look next.
 

·
TSF Team Emeritus
Joined
·
837 Posts
I Am Also having problems with both, the httpd and the proftpd. i have mandriva LE 05 and the proftp and http won't connect to any address outside of the box, but the ssh will...
 

·
Registered
Joined
·
1 Posts
ftp Lone Wolf

Hey Lone Wolf, have you checked for firewall/router settings to permit traffic outside the box?
Gin, I'm working with you off-list.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top