Tech Support banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I've installed proftpd as a standalone server. And made sure it installed in /sw/proftpd-1.2.7/

I did'nt enable shadow passwords from ./configure as i've only come across one place that says to do it, the rest dont. No additional parameters were passed on setup, just enough to install where i wanted it.

I need to access /ftproot/pub using the users ade and lizzy and their respective passwords (normal users), no anonymous and just that folder.

I modified the /etc/pam.d/ftp file as shown in the README.PAM file as follows (this is the complete file) :

#%PAM-1.0
auth required /lib/security/pam_listfile.so item=user sence=deny
file=/etc/ftpusers onerr=succeed
auth required /lib/security/pam_pwdb.so shadow nullok
account required /lib/security/pam_pwdb.so
session required /lib/security/pam_pwdb.so

And then modified proftpd.conf as follows (again this is complete) :

ServerName "LizzynNarn FTP"
ServerAdmin [email protected]
ServerType standalone
Defaultserver on
Port 21
SystemLog /sw/proftpd1.2.7/logs/syslog.log
TransferLog /sw/proftpd1.2.7/logs/xferlog.log
MaxInstances 30
DeferWelcome on
MaxLoginAttempts 3
User proftpd
Group proftpd

<Global>
AccessGrantMsg "Welcome To The Penguins Lair %u"
DisplayConnect /sw/proftpd1.2.7/welcome.msg
IdentLookups off
DefaultRoot /ftproot/pub
AllowOverwrite yes
DenyFilter '%'
DenyFilter \*.*/
Umask 022
</Global>

<Limit LOGIN>
order Allow,Deny
AllowUser ade
AllowUser lizzy
Deny from all
</Limit>

Thats it really, i can ftp to it but it will not allow me in, either as the 2 specified users or anon??? What did i miss?? I know its somthing silly now, but can't see what. The 2 users are members of a group called HOME and the ftproot/pub folders are set to write for the group home and owned by root.


Thanks
 

·
Registered
Joined
·
711 Posts
Have you checked the logs?

I would check your logs and that is going to give you the first idea of where to look, there's so many variables it'd be hard to say. Altho I've never had anything but bad luck with PAM auth.. but thats just me :( Anyways see if you can dig up some log info and post that here as well....
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
I've checked the log files. All it says is connection refused for user (name of user im connecting as).

All i want is for 2 users that i specify (normal users), to access one folder that i specify, with full access, and no anonymous access at all. I'd have thought this a simple task. All i've done as i said, is install the package and edited proftpd.conf, and also edited /etc/pam.d/ftp (this i was told to do from the install instructions). Someone has mentioned somthing about ftpusers.db, in another forum, but i've not seen anything in any documentation about this problem.
 

·
Registered
Joined
·
711 Posts
Did you install ProFTP from source or from a Redhat supplied RPM? I don't recall if there are PAM logs on redhat, but you might try investigating those as well.
 

·
Registered
Joined
·
711 Posts
eh, the problem "probably" lies in the fact that you didn't enable shadow passwords..

PAM=Pluggable auth modules (I never got them to work personally and they're a pain in the ***)

Shadow Passwords /etc/shadow file contains usernames/passwords <~~encrypted passwords for all system users..

I'd suggest re-compiling and then installing with shadow passwords enabled.. just my 2 cents
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top