Tech Support Forum banner

Problems with USB HDD

892 Views 6 Replies 2 Participants Last post by  Lydokane
I'm having problems with my USB 1TB external drive. My Windows 7 machine only sees it as a USB 1.0 device. This has just recently started happening. I know it is a 2.0 device. I updated my USB drivers and I do not have problems with any of my other external drives and/or flash drives.

I tried to delete and recreate the partition and format then run check disk. No errors were detected. I've tried removing all other USB hardware (leaving only mouse & keyboard) and just run the external drive. I am also using a cable that is certified 2.0 compliant.

It is a Verbatim 1TB drive (

Any ideas?

Not open for further replies.
1 - 7 of 7 Posts
Hi, I would RM (take back to where you purchased it) the unit, it has a controller that is supposed to read the USB port speed 1.1 or 2.0 looks like it is only reading 1.1. Has happened to us before (we see a lot of these though, so I don't think the unit is a bad buy (pricey though).
I am trying to do that now. Unfortunately, when I call tech support, I get an Indian guy named 'Robert' who is telling me that it can't be the hard drive and that I have bad USB drivers. If I continue to get the run-around I can honestly say that this is the last Verbatim product I will ever buy.

I think I will keep this thread alive until the issue is resolved. This way others can see what a support issue is like with Verbatim.

Thanks for the quick reply.
Hi, well it is easy to test just put it into another computer.
I have tried two desktop and one laptop computer. The results are the same. I have tried two different cables. No luck.

I just got an RMA from tech support. I was told that I have to have the original box and all original packing as well as the receipt or the RMA department will not review my claim. This is starting to sound like a load of crap to me. I've had the drive for around nine months. I can't keep the boxes to every piece of technology I buy. I would have to rent the house next door just to catalog and store all the empty boxes.

I think I'm going to try to call tech support again tomorrow during normal American business hours and hope to talk to someone local. The whole box/receipt thing sounds kind of fishy to me.
Hi, there is something you might like to try, will do no harm follow this:-

1. Open a Windows Explorer window by right clicking on Start and
then clicking on Explore.
2. In the address bar, type C:\windows\inf and press Enter.
3. Find and then right click on the file named INFCACHE.1.
4. Select Properties.
5. Click on the Security tab.
6. Click on Edit to edit the permissions of the file.
7. Click on Add to add User Groups.
8. Type Administrators in the User Groups field and click on OK.
9. Set Administrators to Full Control and click on OK.
10. Move or delete the file INFCACHE.1.
11. Reinstall a device to force Windows to rebuild the INFCACHE.1 file
(DO NOT reinstall the same external hard drive that you were having
issues detecting before. Please connect another USB device other than
the one that Vista had an issue detecting).
See less See more
Thanks for your help but I think I'm going to pursue the RMA. The main reason I purchased this drive is for my digital multimedia player. I was storing all the disney movies for my kids and playing them back with the DMP. My DMP does not read USB 1.0 devices and right now it will not read this drive. I'm fairly certain that you were correct early on when you said the USB controller is defective. If Verbatim screws me I will either pull the HDD and run it as an internal in my PC and buy another (non-Verbatim) external or I will pull the HDD and buy a different external enclosure.

I'm still going to keep this thread alive for now just for follow up purposes.

Thanks for all your help.
1 - 7 of 7 Posts
Not open for further replies.