Tech Support banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi everyone,
Here is my latest Vista woe(s). (Dell Inspiron 1420, 2gbRAM, 160gb HDD, Core2duo T5450 1.66GHz, Vista Home Prem - auto update, AvastHome, Windows Defender, AVGAntispyware, RUBotted, Threatfire)

Some background:
I have 3 profiles on the machine. Admin which is my original Admin account (I've used it to install apps etc); Basic which is my everyday, non-admin profile that I use for just about everything; New Admin which is a new admin account I created for trouble shooting but it has the same problems that the original one has.

There are 2 basic issues (I'll use one particular instance as an example but it's not the only instance AND it's an intermittent issue - sometimes problem happens sometimes it doesn't. Ten minutes after this instance I downloaded and installed an app and it ran fine):

1. In my Basic profile I downloaded Skype and saved the file to my Public Downloads folder. I right-clicked "run as administrator" to try and install and got this error:

Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.

I tried just clicking it to run it (without "run as administrator") and got the same error.

I did some searching on the error and found some postings elsewhere but most were very old and in WinXP instead of Vista but I tried investigating the things mentioned in those posts.

- I ran the AVG scan and removal tool for the Gaelicum.A virus - it didn't find anything.
- I checked the properties of the file and it did not say anything about coming from another computer and needing to be unblocked.
- I logged out of my Basic profile and logged into my Admin profile and all the same problems happened.
- I logged into my New Admin profile and all the same things happened.

In my New Admin profile I copied the file from the Public Downloads folder and tried pasting it into my New Admin's own Downloads folder and got this error:

Destination Folder Access Denied
You'll need to provide administrator permission to copy this file. (NOTE: This happened IN MY ADMIN PROFILE)


Click "Continue" and get this message:

User Account Control
Windows needs your permission to continue. If you started this action, continue.
File Operation
Microsoft Windows 3AD05575-8857-4850-9277-11B85BDB8E09


Click "continue" and the installer begins. It runs a while and then I get this message (the dialog box says its a message from Skype but I've gotten similar messages from other software I've tried to install):

Cannot write the installation package on the disk. Please make sue that you have the necessary disk space available.

There are 131GB available on this disk.

This is not a new problem so I can't think to associate it with any particular software change and so 'restoring' to an earlier time isn't helpful because it's not tied to any particular time that I can identify. I haven't changed hardware.

AND...the associated issue (at least I think it's associated) is that sometimes installing apps in one profile doesn't flow thru to the other profiles and I can't find any rhyme or reason to that - I've had this happen whether I install the apps while in my Admin account, while in my Basic account and using "run as administrator" to install, or whether I'm in my Admin account and using "run as administrator" EVEN THOUGH I'm IN MY ADMIN account because some apps seem to require that kind of thing.

Then the icons for that app won't show up in different profiles' start menus, I can't even search for the apps - have to sometimes dig into C:\xx...\ to find an executable to create a shortcut. Sometimes then trying to run the app (and I'm talking about something basic like maybe a PDF viewer or something like that) it says I need administrator permissions to run it.

I'm so tired of all this. Can someone please help me? I'm hoping that by giving all this info at the start it will help rule out a bunch of stuff and make it easier to zero in on the issue.

Thanks in advance.
Buck
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
Helloooooo??? Anybody out there?

I'd really appreciate any help you can offer me.

[UPDATE] incidentally, since writing this I have been able to install a couple of other small apps (but have also run into the same problem on a couple of others).

Thanks
Buck
 

·
Administrator, Manager, Microsoft Support, Acting
Joined
·
34,380 Posts
When you speak of the various admin accounts - is one of them the "hidden" Vista admin account?

When installing any application, you should download to your desktop - then install from there. Make sure during install if the option is there that you select "all users" if you want all user accounts to have the ability to run it.

regards. . .

jcgriff2
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Thanks for your reply.

Re Admin accounts, I have the original one set up when first setting up PC, I have another I made thru regular processes of adding a user, and I have another that I created via instructions from someone on another tech support forum using the CMD feature and the following: net user administrator /active:yes (which also didn't work/solve problem)

So now there are 3 admin accounts at my startup screen along with my everyday basic account and the guest account.

I appreciate your reply but it raises 2 issues for me - 1. I'm not a complete newbie - I shouldn't have to save everything to my desktop to use it - I save things to a public download folder so I can see them from any profile if necessary; 2. the issue I'm having isn't addressed - there's still no reason why something I put into a public folder isn't accessible to the profile that put it there, and isn't accessible to an Admin profile.

I always use the "all users" feature when it's offered by an install program (which is rarely) but isn't/shouldn't the default be to make installed apps available to all user profiles.
 

·
TSF - Enthusiast
Joined
·
12,841 Posts
the best way I find to get past the annoying security issues is to edit your permissions

go to properties - security - edit -

then put it on full control for your user then if that doesn't work keep adding "full control" to the rest of them

even though I have just one passworded admin account it still has like 4 users
-Authenticated users
-System
-Administrators(User\PC\Administrators)
-Users("User-PC"\User)

I'm usually worried about the permissions of the middle two and when installing apps and moving things it should always be done as an admin.
 

·
Registered
Joined
·
1 Posts
I am having the same problem - I've just restored my HP Pavilion m8010y computer from scratch, taking care to follow Vista installation instructions on software and have never left Administrator mode. The only software I suspect may have changed performance are yesterday's installs (HP Scanjet, Ulead VideoStudio 11 Plus after patch, Quicken, printer software, SnagIt 9) since I had a little copy-paste trouble after.

Today I downloaded pictures from my camera to the Picture Folder and then split some off into other subfolders. Then I used the Menu "Edit - Move to Folder" command to transfer them to an HP Media Drive. Even though all of the 187 pictures showed up on the Media Drive, a half a dozen pictures remained and one subfolder. I can't move them, delete them or copy them. I can't even open the subfolder that remained. It also won't let me change ownership - it treats it as though it was a Microsoft system file. Any suggestions?
 

·
Administrator, Manager, Microsoft Support, Acting
Joined
·
34,380 Posts
Thanks for your reply.

Re Admin accounts, I have the original one set up when first setting up PC, I have another I made thru regular processes of adding a user, and I have another that I created via instructions from someone on another tech support forum using the CMD feature and the following: net user administrator /active:yes (which also didn't work/solve problem)

So now there are 3 admin accounts at my startup screen along with my everyday basic account and the guest account.

I appreciate your reply but it raises 2 issues for me - 1. I'm not a complete newbie - I shouldn't have to save everything to my desktop to use it - I save things to a public download folder so I can see them from any profile if necessary; 2. the issue I'm having isn't addressed - there's still no reason why something I put into a public folder isn't accessible to the profile that put it there, and isn't accessible to an Admin profile.

I always use the "all users" feature when it's offered by an install program (which is rarely) but isn't/shouldn't the default be to make installed apps available to all user profiles.
Hi. . .

Thanks for informing me of your technical ability - as I really have no way of knowing such when providing advice.

The last account that you set up using the net user command is in fact the Vista hidden admin account (SID ending in -500).

My advice about downloading to your desktop involved nothing other than program installation files. It has been my experience (first hand) that if you install a program contained on a USB, DVD, or even the public file, Dependant upon the program - it sometimes refers back to the original installation module. So if you install a program from one of these areas and the file is not there (USB/DVD removable) or in the case of the public file - the system may find it "in use", it may fail.

Furthermore, creating a shortcut in the public folder on your system will invoke the user profile variables, which are just that - variable. So a shortcut in your public folder would execute the program on your system, where some other system using that same shortcut would either attempt execution on their system - or possibly on yours (Dependant upon setup), which the other system would not have adequate permission setting required on your system.

When you download a file, it is downloaded to the temporary storage areas found within your user profile, then copied out to the location that you actually selected. During program installation, your user profile folders are used once again.

I tested a program installation from my public folder with mixed results. The public folder allows file sharing of IT - not of your entire system. You could go through and change permission settings and file ownership to possibly accomplish your goal. I have systems in my home that can access various folders across systems. But I cannot run a program from one and have it fully execute on another due to such permission settings.

If you provide additional detail - the exact program and steps for installation and any subsequent steps, I will gladly test the same here and provide you with my results.

Finally, have you cleaned out your temporary storage areas? The insufficient disk space message may be referring to such. I suggest that you use CCleaner, found HERE.

Regards. . .

jcgriff2

.
 

·
Registered
Joined
·
1 Posts
I have a problem with I.E. 7...
For some reason it won't let me open(under "Tools") "internet options", says I need the administrator to be able to do this.
I am the administrator, and there is NO guest "on".
What do I do to "quick fix" this?
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top