Tech Support banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Greetings,

This is a problem that I have already partly solved, but I'm not completely happy with my solution.

I have recently upgraded from IE7 to IE8 on a laptop running Vista (SP2).

While IE would load my home page (Google) without any problems, just about any other page would take minutes to load - if at all.

Eventually, I fould that switching off "Protected Mode" on the Security options changed this. Now, pages load just as fast (or slow) as they did with IE7.

Q1: Despite all of the warnings from Microsoft, is there any "real" danger in switching Protected Mode off? (I am also running the full set of Internet Security apps from Computer Associates, if that makes any difference.)

Q2: Is there some other fix to my problem that does not involve disbling Protected Mode?

Thanks in advance

D
 

·
Pass The Oreos
Joined
·
622 Posts
Q1: There's no real danger in switching off "Protected Mode", you just need to be careful on what you click on every website and avoid clicking on 'ads and pop ups'. I think that's the best protection you can do for your computer.

Q2: I find IE8 to be very slow, it might be because of it's features and how it looks but I preferred using Firefox and IE6/IE7. I also use ccleaner for my browser which I think is worth using and installing.

Hope this helps :smile:
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top