Tech Support Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I’m looking at a problem with a high end graphics printer (OKI PRO 9542WD) which has been successfully connected through an upstairs switch, via a downstairs switch, into a Draytek Vigor ADSL modem/router/firewall for a number of years. All other devices on these two switches both upstairs and down work fine. The printer is reserved an IP address of 192.168.0.35

We recently switched to a Virgin media service and were given a Hitron Chita router to replace the Draytek ADSL. Once we successfully switched to the new service, we ran for a number of days without having to switch on or use the printer.

On Thursday, we switched it on and couldn’t communicate with it from a PC on the network. On further inspection, the printer had self assigned a 169.x.x.x address. The added complication is that we can’t get into the settings for the printer because the supplier has not supplied the admin key to get into the control panel.

After much head scratching, I plugged the printer back into the old Draytek router and it immediately got its usual 192.168.0.35 address, which is reserved for it in both routers. I moved it back to the new Hitron router, it kept its IP address and could now be seen by other devices on the network. As soon as we switched it off and on, it reverts back to its unconnected 169.x.x.x address.

If I could get into the admin area of the printer, I would statically assign that 192.168.0.35 address to it to see if it would keep it and stay connected. However I’m baffled as to why the Draytek router successfully assigns an IP address and the Hitron does not. All connections are the same in both cases, except a single cable moved from the Draytek to the Hitron.

Factory reset of the Hitron? Update Firmware? Sling it in the bin?

Any suggestions welcome.

Thanks.
Luca
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,461 Posts
My educated guess would be that your new router is on a different subnet. You can confirm that by typing ipconfig /all from a command prompt on any computer connected to the new router. The Default Gateway will show your ip address and subnet in use. If I'm right, the reason your printer comes back with an APIPA 169 address is because it can't pull the static 192.0.x.x while connected to a different subnet, say 192.1.x.x

I would plug the old router back in then try logging into the printer with the default credentials - admin / 999999 and see if you can reset it back to DHCP. If that doesn't work, get the user manual and do a factory reset, which will put the network defaults back to DHCP. The other easy option is to change the addressing of your new router to match the old one.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
My educated guess would be that your new router............
Hi Fred, Thanks for the reply. Both routers dish out IP addresses in the same range and subnet. The new router is exhibiting other behaviour that makes me think it's a bit of a dud. We haven't tried "999999" as the OKI password, We were told six zeroes or "123456" or the serial number of the printer. I'm going in tomorrow and I'll give that a go.

LV
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,461 Posts
Hi Fred, Thanks for the reply. Both routers dish out IP addresses in the same range and subnet. The new router is exhibiting other behaviour that makes me think it's a bit of a dud. We haven't tried "999999" as the OKI password, We were told six zeroes or "123456" or the serial number of the printer. I'm going in tomorrow and I'll give that a go.

LV
Too bad that wasn't it. I see it happen a lot with used copiers & printers. Try the different default username and password combos and see if any of them work. You should still be able to do a full reset to defaults using a combination of buttons on the printer. Check the manual for steps how.

If you don't make any progress, connect a computer to the same network cable that the Oki is connected to along with the new router then run an Ipconfig /all. Save the output to a .txt file if needed and post the results here. That will help verify an endpoint can properly get an IP address and rule out a wiring, switch, vlan or subnet problem upstream of the printer.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
Too bad that wasn't it. I see it happen a lot with used copiers & printers. Try the different default username and password combos and see if any of them work. You should still be able to do a full reset to defaults using a combination of buttons on the printer. Check the manual for steps how.

If you don't make any progress, connect a computer to the same network cable that the Oki is connected to along with the new router then run an Ipconfig /all. Save the output to a .txt file if needed and post the results here. That will help verify an endpoint can properly get an IP address and rule out a wiring, switch, vlan or subnet problem upstream of the printer.
Thanks again for the reply. I’m spending most of tomorrow troubleshooting this. We’ll switch over temporarily to the other router & ADSL service (a lot slower) and reset, start from scratch, possibly update the router firmware. The VM router has some very temperamental annoyances, which is why I’m still convinced it’s the culprit.

On the cable front, we’ve tried several. Different sockets on the upstairs switch and a very long cable down the stairs directly into both routers.

If it turns out to be the VM router, they’ve got a lot of splaining to do.

LV
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #9 ·
A mixed bag from yesterday. I found out that the Hitron Chita router, as delivered by virgin media does not have a menu item allowing you to set modem mode as others have suggested in another forum. If you factory reset the device and don’t put in credentials for a static IP address, neither modem mode appears in the menu as it used to in the older CGNV4, nor does the router connect to the Internet properly. I still don’t understand how others have switched on modem mode with this router.

On a positive note, thanks to earlier responder, I managed to get into the OKI printer and change the network settings to the reserved static local IP. When I did this, it was fully connected and available to use on the virgin media router.

LV
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,461 Posts
I don't understand your first paragraph or what modem mode is. Maybe that's something your ISP can help with? Unless you're referring to having to enter your ISP account credentials into the modem in order to connect and get online. That's typical of ASDL as far as I know.

So what was the problem with the network connection to your printer, do you know?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #11 ·
I don't understand your first paragraph or what modem mode is. Maybe that's something your ISP can help with? Unless you're referring to having to enter your ISP account credentials into the modem in order to connect and get online. That's typical of ASDL as far as I know.

So what was the problem with the network connection to your printer, do you know?
Virgin Media used to allow customers to hook up their own Router/Firewall to their equipment. You put their router into modem mode (their wording) and then you can get DHCP, Port Forwarding, Firewall etc running on a half decent bit of kit that is industry standard. We had a Draytek Vigor ready to go for this. It seems this new hardware does not allow mode mode, as far as I can see, or at least this version of the firmware doesn't. The router configuration pages are heavily branded with Virgin Media own logos etc. Probably not much mileage in updating it independently. At some point, we'll go on hold for an hour and get the instructions for enabling modem mode on the hardware they supplied and try again but their website only gives instructions for an older one.

With the printer, I read the post that a previous responder suggested and got into the admin area of the printer. I set manual IP address with the details of the IP address already supposedly reserved by the Virgin Media router and it worked. We can now see it on the network. Setting it to Auto and getting the Router to issue an address still doesn't work. Not sure I understand why still.

LV
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,461 Posts
OK, I understand what you mean now. You want to use the Virgin supplied device as as a modem only and turn off the router and DHCP functions so you can use your own router.
 
1 - 14 of 14 Posts
Top