Tech Support banner

1 - 15 of 15 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1 (Edited)
Hi everyone,
I'm trying to run a dedicated server for Ark: Survival Evolved and I've entered all the ports into port triggering but whenever I check to see if the connection is visible (querying port 27015) on sites such as canyouseeme.org, the site says:
Error: I could not see your service on <IPADDRESS> on port (27015)
I've read that Ark requires the following ports to be opened:
  • TCP: 25147,27015-27030,27036-27037
  • UDP: 4380,7777-7778,25147,27000-27031,27036
and my port triggering is configured as follows:

Full disclaimer, I have no idea if I've configured the port triggering properly. I was pretty confident with port forwarding but I'm pretty clueless with port triggering.

Also I read that running telnet 127.0.0.1 27015 would query the port but that returns:
Connecting To 127.0.0.1...Could not open connection to the host, on port 27015: Connect failed.
I've had the exact same issue with other games in the past on this PC and different modems so I'm not entirely certain that the modem is the problem.

Any ideas what could be the issue?

Modem/Router Make/Model: TP-Link Archer AX1500
Hardware Version 1.0
Firmware Version: 1.0.8

OS: Windows 10 Professional 64 bit
Motherboard: Asus PRIME X299-A
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,054 Posts
I'm not familiar with your router or what Ark is, but I'd try using Port Forwarding rather than Port Triggering.
  • First, assign a static or reserved LAN IP address to your server
  • In your router under Port Forwarding, enter the ports you want to open then point them to the LAN IP address for your server. E.G. - Port 25147 ---> IP 192.168.1.x
  • You should double check the manual for your router as to how to enter multiple port ranges. Usually just entering a dash between the port #s is correct, such as: 27015-27030
Try it that way with a single port or 2 and see if they're open.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #3
Hi Fred,

Thanks for your reply. Ark is just a video game - I've tried with port forwarding just now with the following configuration:
329497


But even now when I try on portchecktool, it still says connection timed out when querying port 27015 or 7777. The server is running locally on my own PC and it has a static IP.
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,054 Posts
  • Try adding port 8080 and open it the same way to the.100 server then save your settings.
  • Shut down the server and unplug the power to the router for about 20 seconds.
  • After the router is back online, power up the server and do another port check at one of the port testing websites.
  • If that doesn't work, temporarily turn off your Windows firewall and check it again.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #5
Okay I gave that a shot but same result even after disabling the firewall.

329498
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,054 Posts
Under Nat Forwarding in your Router, go to DMZ then enable it and add the 192.168.0.100 IP address. And you're sure your server is using the correct LAN IP, right?

I'd also check for a firmware update from TP Link. It seems anytime I come across this problem it's the router itself.
You might also want to try accessing the router's software page using a different web browser and make your changes. It's a longshot, but I've seen GUI's that were just awful and not compatible with some browsers.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #7
Okay I applied the DMZ (using a different browser) to .100 and confirmed that I'm on .100
329499
.I couldn't find any firmware updates for my router and the web interface says that it's up to date as well.
Checked again but I get the same result :(

I'm not 100% sure if it's a router issue or not, because I've had this issue on my previous router too. The previous router was a different manufacturer but it was still the same computer. Having said that, I have reinstalled Windows since I first noticed the issue and that didn't fix it either.
Could it possibly be an issue with part of my hardware?
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,054 Posts
When you assign your .100 server to the DMZ and enable it in your router, your router passes ALL WAN traffic to the server without blocking anything. So, DMZ basically leaves all ports open. Have you tried running the game server using your current port forwarding or DMZ enabled settings, regardless of what the port forwarding website shows for results?

The firewalls built into today's routers are what does all the port blocking from the outside internet. That's really the only hardware that should be doing anything. Your Windows firewall is software based. You could post the results of an IPCONFIG /All command from a command prompt if you want, just to make sure your network config is right. If it was me, I'd probably do a hard reset on the router and start over.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #9
Hm I see. I haven't tried running the game server with the DMZ just yet just because I don't have another PC to test with. Naturally I'm able to connect to it via localhost but external devices are having the issue.

The dump of my ipconfig /all is:
Code:
Windows IP Configuration

   Host Name . . . . . . . . . . . . : COMPUTERNAME
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Ethernet Connection (2) I219-V
   Physical Address. . . . . . . . . : 10-7B-44-54-31-6A
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 9:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
   Physical Address. . . . . . . . . : 94-E6-F7-9D-8D-B7
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 10:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
   Physical Address. . . . . . . . . : 96-E6-F7-9D-8D-B6
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Wi-Fi 6 AX200 160MHz
   Physical Address. . . . . . . . . : 94-E6-F7-9D-8D-B6
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::e5be:9989:a748:cd83%7(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.100(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Friday, July 31, 2020 4:36:26 PM
   Lease Expires . . . . . . . . . . : Sunday, September 12, 2156 8:56:30 PM
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 412411639
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-26-5D-62-AB-10-7B-44-54-31-6A
   DNS Servers . . . . . . . . . . . : 192.168.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
   Physical Address. . . . . . . . . : 94-E6-F7-9D-8D-BA
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
Would it likely be the router? I'm just reluctant because the issue has occurred on other routers prior to this one. The only thing I've configured on this router is the static IPs. Do you think it'd be worth me having a chat with my ISP? I hear that apparently on occasion ISPs have been known to block ports.
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,054 Posts
Nothing else is coming to mind... Double-check your configuration in the game server software. I doubt your ISP is blocking those ports. You could call them, but you'll most likely end up with an entry level tech on the first call, who may not have accurate info. I'd call TP Link if you can get support from them.
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,054 Posts
Actually, one other thing would be your modem, if you're using a separate one. Not sure if the TP Link is an all-in-one modem & router. If it's supplied by your ISP, some have NAT & firewalls built into them which would be a problem if it's turned on. Comcast has some like that. Your ISP could help with that or change the settings if they supplied it.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #12
Yep it's a modem + router but it wasn't provided by my ISP - I bought it from an independent retailer. I think I might get on to my ISP and TP Link to see what else can be done. Thanks heaps for your help Fred!
If all else fails, I'll get my friend to keep hosting games haha.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #14 (Edited)
Still nothing yet ._.
I contacted my ISP and they noticed that my service was enabled for CGNAT which might be causing the problem. They've disabled that on my service and I'm going to monitor if anything changes.

Edit: I've installed Hamachi and external devices are able to ping mine via this VPN.
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,054 Posts
That's good to hear and CGNAT would be a problem. I didn't know they could enable it when you're using your own equipment.
 
1 - 15 of 15 Posts
Top