Tech Support banner

1 - 17 of 17 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I've been trying to get a csgo server running but it wasn't working and when I check the ports it says they are closed. My current setup in terms of routers and other such devices is as follows: I have a cable modem/router which hooks into another router (The one my pc is hooked into, a RT-AC86U) which is the main router for asus' aimesh. I've done the normal port forwarding procedure on both the RT-AC86U and the modem/router combo, where I opened the ports for the RT-AC86U device that was listed on the router/modem and then opened the ports for my pc on the RT-AC86U, because logically it makes sense to me that if the modem/router is blocking the ports first then they won't be open on the RT-AC86U but this hasn't worked and just having the RT-AC86U port-forwarded to my pc doesn't work either. I've also tried connecting wirelessly to the router/modem and port forwarding to my pc directly from that, and that didn't work. I've also put exceptions in my firewall in windows for the certain ports needed, 27015 and 27005, both UDP and TCP. I've also tried switching the firmware on the RT-AC86U to the merlin third party firmware because I've heard that that can fix some issues, but that, sadly, did not work either. Please help me I am at my wits end with this stuff.
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,160 Posts
eeGeek, you don't connect 2 routers together on the same network. Make sure your cable modem/router is in 'modem only' mode and not acting as another DHCP server.
I'll wait and see if you come back or if this is a hit and run post before offering any other suggestions.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
eeGeek, you don't connect 2 routers together on the same network. Make sure your cable modem/router is in 'modem only' mode and not acting as another DHCP server.
I'll wait and see if you come back or if this is a hit and run post before offering any other suggestions.
Isn't it just a problem that it is running as a DHCP server if it is supplying the other router a new ip regularly? The RT-AC86U has a static/reserved IP on the router/modem and as far as I'm concerned it is acting just as a modem to the RT-AC86U.
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,160 Posts
Sorry, I don't understand your first sentence. Guessing how your modem is configured doesn't help any. You only use One router on a network and you need to make sure your cable modem/router is set up as a Modem Only, if you want to use the RT-AC86U as a router. Pick one and disable the other.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Sorry, I don't understand your first sentence. Guessing how your modem is configured doesn't help any. You only use One router on a network and you need to make sure your cable modem/router is set up as a Modem Only, if you want to use the RT-AC86U as a router. Pick one and disable the other.
Would activating Bridge mode effectively activate modem only mode because I don't see anything that says modem only mode in the modem/router menu, it's an xfinity modem by the way.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
I did some reading and I am pretty sure bridge mode does this, I activated it and the ports are still not open so it doesn't seem to have solved the problem but at least now I only have to deal with one router. Should UPnP be on?
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,160 Posts
Yes, Bridge mode is the correct way to set up the Xfinity modem/router. Make sure to power cycle everything - unplug both devices for about 30 seconds then plug the router in. After the router is online, plug the Asus router power back in.
-If your ports still show as closed, find the WAN IP address in your Asus router, then do a Google search for 'What's my IP' and compare the 2 IPs. If they are different, your ISP is using CG NAT and they will have to disable it.
  • Open a command prompt and type: tracert 8.8.8.8 then press enter and post the results here
  • You can temporarily leave UPnP on in the Asus router in case you have a program that changes settings on its own, but it's best to leave it Off. It's a security risk.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
Hey I unplugged both devices and then plugged the modem back in first waited until it started back up to the state it was before I restarted it and then plugged in the router and the ports are still closed. The IP addresses are the same between the WAN IP displayed by the Asus Router and when I search what's my IP, UPnP is off.
Here are the results from tracert 8.8.8.8:

Routenverfolgung zu dns.google [8.8.8.8]
über maximal 30 Hops:

1 <1 ms <1 ms <1 ms RT-AC86U-C750 [192.168.50.1]
2 8 ms 9 ms 7 ms 96.120.8.97
3 8 ms 7 ms 8 ms 96.110.218.221
4 13 ms 9 ms 9 ms po-2-rur02.lancaster.pa.pitt.comcast.net [96.108.5.34]
5 8 ms 8 ms 8 ms be-53-ar01.lancaster.pa.pitt.comcast.net [96.108.5.93]
6 16 ms 19 ms 16 ms be-34-ar01.mckeesport.pa.pitt.comcast.net [69.139.168.141]
7 17 ms 18 ms 17 ms be-31631-cs03.pittsburgh.pa.ibone.comcast.net [96.110.42.169]
8 16 ms 17 ms 17 ms be-1311-cr11.pittsburgh.pa.ibone.comcast.net [96.110.38.138]
9 25 ms 23 ms 22 ms be-301-cr12.ashburn.va.ibone.comcast.net [96.110.39.165]
10 23 ms 22 ms 22 ms be-1212-cs02.ashburn.va.ibone.comcast.net [96.110.32.205]
11 25 ms 22 ms 22 ms be-2207-pe07.ashburn.va.ibone.comcast.net [96.110.32.190]
12 17 ms 21 ms 21 ms as15169-4-c.ashburn.va.ibone.comcast.net [173.167.57.162]
13 21 ms 25 ms 22 ms 66.249.94.4
14 22 ms 21 ms 21 ms 216.239.48.201
15 21 ms 21 ms 21 ms dns.google [8.8.8.8]

Ablaufverfolgung beendet.

my computer isn't in english but that text doesn't seem too relevant.
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,160 Posts
OK, that looks good and it doesn't seem like you have dual NAT going on with your ISP. I thought there was something else that needed to be changed in the modem, but I don't remember or have access to a Comcast modem at the moment.

Do you have port forwarding set up correctly in the Asus router? Your PC should have a static LAN address = 192.168.50.xxx then in the port forwarding page of your Asus, add the individual port #'s you want forwarded from the WAN to the 192.168.50.xxx address of your computer and save the settings.

Other temporary tests: If you enable DMZ in your Asus and assign your PCs LAN IP address to it, that unblocks everything and your ports should appear open. Temporarily turn off your Windows or antivirus firewall for testing, too.

If your ports still show as closed, call your ISP and have them confirm your connection isn't using any type of CG NAT and that your modem is correctly configured for use with your own router. Let them know you're trying to open ports to play a game. They have the ability to log into your modem and verify bridged mode is set up correctly. Another test is to plug your PC directly into the modem and check your ports again. Plugging directly into your modem eliminates the router and firewall protection of your Asus router so you shouldn't have any ports blocked, though it's not safe to leave it that way.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
I tried activating DMZ and using the port checker at canyouseeme.org which supplies a reason for the port being closed and normally it says Reason: connection timed out but for the port 27015, the only port I have in the port forward list currently, it gives the Reason no route to host. I have a static IP set for my PC and as far as I can tell the port forwarding is set up correctly.

330872

where 192.168.50.3 is the IPv4 of my PC
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,160 Posts
When you run the port checker, do you have the program using port 27015 open and running?
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,160 Posts
Forget about canyouseeme - Try testing your program or whatever you're trying to get running and see if it works.
The online port checker tools are only going to show your ports as open if you have the program open and listening.
 

·
Registered
Joined
·
13 Posts
I've been trying to get a csgo server running but it wasn't working and when I check the ports it says they are closed. My current setup in terms of routers and other such devices is as follows: I have a cable modem/router which hooks into another router (The one my pc is hooked into, a RT-AC86U) which is the main router for asus' aimesh. I've done the normal port forwarding procedure on both the RT-AC86U and the modem/router combo, where I opened the ports for the RT-AC86U device that was listed on the router/modem and then opened the ports for my pc on the RT-AC86U, because logically it makes sense to me that if the modem/router is blocking the ports first then they won't be open on the RT-AC86U but this hasn't worked and just having the RT-AC86U port-forwarded to my pc doesn't work either. I've also tried connecting wirelessly to the router/modem and port forwarding to my pc directly from that, and that didn't work. I've also put exceptions in my firewall in windows for the certain ports needed, 27015 and 27005, both UDP and TCP. I've also tried switching the firmware on the RT-AC86U to the merlin third party firmware because I've heard that that can fix some issues, but that, sadly, did not work either. Please help me I am at my wits end with this stuff.
I think you're making this far more complicated than it needs to be. Pick one of your routers to connect to the incoming cable, and put the other one on a shelf somewhere as a spare. There are normally seven rj45 connectors on a router, and, should more be needed, they can be added with a router bridge. Performance through a bridge is identical to that when hooked directly to the router. Having either done one, removing the second router, or the other, installing a bridge, the port forwarding is set for all devices through the router configuration pages online.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #16 ·
I think you're making this far more complicated than it needs to be. Pick one of your routers to connect to the incoming cable, and put the other one on a shelf somewhere as a spare. There are normally seven rj45 connectors on a router, and, should more be needed, they can be added with a router bridge. Performance through a bridge is identical to that when hooked directly to the router. Having either done one, removing the second router, or the other, installing a bridge, the port forwarding is set for all devices through the router configuration pages online.
As it currently stands the router/modem as stated in the original post is just a modem connected to the asus router that I am connected to, if there are any suggestions the ports are still listed as closed according to online port checkers.
 

·
Team Manager - Networking , Moderator - Micros
Joined
·
4,160 Posts
Have you actually tried Using your game server?? As I said before, the port check websites will show your ports as closed if the server isn't running.
 
1 - 17 of 17 Posts
Top