Tech Support Forum banner
Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
My computer got the vundo virus, which was bad enough, but it wouldn't let me reboot into safe mode. My genius brother told me to go to MSCONFIG and change the boot.ini to safe mode to get in that way. Now it TRIES to boot to safe mode, can't and is in perpetual try-reboot mode. I am unable to get into my computer at all!! I need it and my files for work. Can someone help before I find a building to jump off?
 

·
Visiting Expert, Microsoft Support Team
Joined
·
937 Posts
Problems that can occur by forcing Safe Mode using the System Configuration Utility
http://www.bleepingcomputer.com/tutorials/tutorial61.html#force_safemode
If a situation like this has happened to you it is possible to fix this problem by renaming your boot.ini file. The first step would be to use a boot disk to start your computer. If your computer does not have a floppy disk, then you can typically boot off the Windows CD that came with your computer in order to access the Windows Recovery Console. More information about the Windows Recovery Console can be found here. Once booted to a command prompt, you would simply rename your C:\Boot.ini file to another name like C:\Boot.ini.bak. The command to rename the file at the command prompt is:

ren C:\Boot.ini Boot.ini.bak

Once the file is renamed, you can then remove the boot disk and reboot your computer to get back to normal mode. When booting up after the rename, do not be surprised if you see an error stating that you do not have a valid Boot.ini file. When you get back to normal Windows mode, you can then rename C:\Boot.ini.bak to C:\Boot.ini and run Msconfig again to remove the /safeboot flag.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #6 ·
OK, will give it a shot tomorrow. (Someone sleeping in the room where it is now, lol). Even when I get back in, I have to deal with the Vundo.h virus --sounds like its tough enough to survive Fdisk.... Thanks for answering folks, I appreciate it.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #8 ·
Hi--the reboot worked after I renamed the boot.ini file to boot.ini.bak in the revocery console. Now I am back in, but I need to name the boot file back to boot.ini --how is this done?
 

·
Visiting Expert, Microsoft Support Team
Joined
·
937 Posts
Hi--the reboot worked after I renamed the boot.ini file to boot.ini.bak in the recovery console. Now I am back in, but I need to name the boot file back to boot.ini --how is this done?
Firstly, do this ....
Show hidden and system files and folders by doing the following:

Launch Windows Explorer by opening "My Computer". On the menu bar, go to
Tools > Folder Options > and click on the "View" tab
Using the scroll bar at the side of the dialog box, find and check-mark "Show hidden files and folders", UNcheck "Hide protected operating system files (Recommended)", and also UNcheck "Hide extensions for known file types".
Click "Apply to All Folders", click "Apply" and click "OK".

Now, find the boot.ini.bak file by navigating to C:\ drive.
C:\boot.ini.bak

Right-click on the boot.ini.bak file and choose "Rename"
Remove the .bak from the file name.

If you receive any (read only) messages, right-click on the file and choose "Properties" and remove the check-mark from the "read only" box.

Check your msconfig boot.ini tab now, and remove the Safe Mode boot setting.
------------------------

Check that your computer will now start/restart normally.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #13 ·
Someone told me to do the following:Open a Command Prompt and type the following and press Enter after each line. This assumes you renamed it boot.ini.bak,(I did). I've exagerated the spacing just so you can see where a space is needed, you only need one space

CD \
attrib -H -R -S boot.ini.bak
rename boot.ini.bak boot.ini

Unfortunately, when I did this my computer said “file not found” and “The system cannot find the file specified.” I was very careful to double check that I followed these instructions and didn’t hit wrong keys.

I tried entering attrib b*.* at the prompt, and it comes back “File not Found.”

If I try to go to start>run>msconfig to try to get out of the boot to safe mode thing, there is NO TAB for Boot.ini any more.

So now what do I do? I really really need help!
 

·
Registered
Joined
·
17 Posts
Type the following in the command prompt:
C:<enter>

if the prompt says anything but C:/ then hit CD..<enter> until it does.
type
DIR/W/P<enter> look for the file boot.ini.bak
if its not on the list try
attrib -H -R -S boot.ini.bak

if it is on the list go ahead and rename using
rename boot.ini.bak boot.ini


Good luck :)
 

·
Visiting Expert, Microsoft Support Team
Joined
·
937 Posts
Open "My Computer".
Double-click on your system drive (probably C: drive).
You are now in the C: folder.
Look in that folder for the file "boot.ini.bak".

You will need to ensure that you have enabled "Show all hidden and system files and folders" as I instructed earlier.

Once you have renamed the file to "boot.ini", the tab should then be visible in msconfig.

Edit: You might be interested in another way of doing the same job .... but as you will see that method too, is not entirely free of "obstacles".
http://www.techsupportforum.com/f10/blue-screen-safe-mode-boot-loop-429315.html#post2476069
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top