Tech Support banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have been a (mostly) satisfiled user of this motherboard. I set up two RAID 0 arrays, one on the SATA chip and one on the VIA IDE Raid chip. When I originally set it up, I was in a hurry, didn't write anything down (I know, I know..) and now I do not totally remember how I did it. I remember it seeming trivial, which is why I am really bugged right now!!

I have upgraded the BIOS to version 1010 (the latest) on my ASUS P4P800 Deluxe motherboard, and from that point I have lost one of my RAID 0 sets!!

Here is my configuration:

Pentium 4 2.8Ghz 800 MHz bus HT processor
2 x 512 PC3200 Memory in Dual channel configuration

Onboard ATA100:
Primary master - DVD drive
Primary slave - 20 GB Western Digital Hard Drive - contains old data
Secondary master - CD-RW drive
Secondary slave - none

Onboard VIA 6410 IDE Raid:
2 x 40 GB Maxtor ATA133 Hard Drives, 1 in each channel, RAID 0. This is the system/boot partition, containing my Windows XP installation.

Onboard SATA:
2 x 20 GB Western Digital ATA100 Hard drives with Serial ATA to Parallel ATA adapter, RAID 0. This hosts some data and some virutal machines.

This configuration, with one RAID 0 array each on SATA RAID and the IDE RAID controller, has worked flawlessly for the past several months. When I upgraded the BIOS, it seems that I was no longer able to have both RAID 0 arrays active at the same time. When I enable SATA as RAID, the drives connected to the VIA IDE RAID controller are no longer detected by the AMI BIOS (they are still detected by the VIA VT6410 BIOS). Since the BIOS cannot see these drives I have no boot partition and I cannot boot my system. When I do not configure SATA as RAID, the IDE RAID disks are detected and I can load Windows fine, but the RAID array on the SATA controller is not functional. Windows sees two separate IDE disks instead of the 40 GB array. Enhanced mode is on. Is there some setting that I might have missed to get me back to using both RAID 0 arrays again?

Thank you.
 

·
Guru
Joined
·
1,315 Posts
(Disclaimer: I don't do RAID.)

One thing I want to say is that whenever updating BIOS it is a good idea to 1.write down ALL your previous custom settings before updating, then 2.update, then 3.perform a "Load Setup Defaults" action. For your mobo it's found under the "Exit" screen. That's because this will make sure that any config fields that either changed how they work, moved locations, or were added in the new BIOS version, will be correctly set to something sensible. Then 4.finally you go back through and reapply the custom settings. I had written a little primer about this, it's Asus P4P800/P4C800 Series: How to Update BIOS.

So even though you probably didn't write stuff down, you still might want to try setting defaults anyway, then go back in and tweak your "Advanced"- "Onboard Devices Configuration" to enable the "Onboard VT6410 RAID Controller", enable RAID on your SATA ports, etc.. There really isn't anything else in mobo BIOS to tell it you want to run the VIA in RAID mode or not; there is for the ICH5R's SATA, but not the VIA.

I checked your mobo manual and it looks like the VIA setup utility (hit Tab key during POST) contains a "Select Boot Array" option (section 5.4.6) which you might need to select-- maybe that's why you can't boot these disks. Usually when they update a mobo BIOS, Asus brings in a new RAID BIOS too --I think it's just all stored in the same flash mem. So maybe by updating, it forgot your settings, so you might just need to go back in and tell your VIA BIOS what you've got. You said it sees the drives, so maybe it just needs to know that they're for booting. NOTE: You should not need to reformat or recreate any RAID sets-- if it tries to make you do that, don't! Stop and look for other answers instead.

Next go back into mobo BIOS and see if you have a "Boot"- "Hard Disk Drives" menu selection (with >1 drives installed, this menu will be present). Open that, and under it adjust the order so that the RAID disks on your VIA appear as "1st Drive"; sorry I don't do RAID, so I don't know what you'll see when you try that, hopefully something about the VIA. Any other disks appearing here (as 2nd, 3rd, etc.) should probably be changed to "Disabled", because it sounds like you prefer to boot only from the VIA RAID-0.

After checking the Hard Disk Drives menu, also check the "Boot"- "Boot Device Priority" and make sure your VIA drives are now coming up as the only hard-disk choice. You might need to hit F10 to save & exit, then reboot and come back in again, to make them show up; I don't know. In the end, hit F10 to Save & Exit, then reboot. Let me know what you find out.

Hope this helps,

-clintfan
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3 (Edited)
Thanks for your reply. Like everything I get frustrated with, I took a day away from it and came back and thought it through.

When I enabled the SATA for raid and rebooted, once again the AMI BIOS lost the two disks (or so it seemed) that were connected to the VIA controller, and the Hard Disk priority changed form "VIA RAID" to one of my other disks. I changed the disk priority back and rebooted and the same thing happened. Then I went in to the VIA BIOS and ensured that my array was set to boot. The funny thing is, though it was set the whole time, the simple act of going in to the VIA BIOS boot settings seemed to fix my problem. Now I have both RAID sets back and am happy with that :)

Unfortunately, secondary IDE seems to no longer be working. When I flashed the BIOS I initially could see my CD-RW drive which was master on the secondary IDE, but shortly after it disappeared. Changing secondary slave from Auto to CDROM gives me a "non-ATAPI device" error during POST. Ah, well, ya can't win 'em all :)
 

·
Guru
Joined
·
1,315 Posts
the simple act of going in to the VIA BIOS boot settings seemed to fix my problem.
Glad that fixed your bootup.

I initially could see my CD-RW drive which was master on the secondary IDE, but shortly after it disappeared. Changing secondary slave from Auto to CDROM gives me a "non-ATAPI device" error during POST.
Hmmm, not sure what you mean by "changing...from auto to CDROM...". I thought the stuff on the BIOS Main screen was all auto-detected, not something you can "change". If there's something changeable, then I would leave it as Auto the way it was before. Oh yeah, I see it now... you highlighted the Secondary IDE Slave, then hit Enter, and changed the Type from Auto to CDROM.

No, don't do that... put the Slave back to Auto. If you've tried to debug by moving your CD-RW to slave and leave the master unattached, I don't think it will work right, not even if you strap the CD-RW for slave. Bus signalling is the reason: when you have only one IDE device on the line, for proper bus termination it's supposed to be at the end of the cable, not the middle. This implies it's also supposed to be the master. It's supposedly not OK to leave the master connector flapping in the breeze and just hook up a slave.

You had your CD-RW as Secondary Master before. So check the strapping on that drive, make it's set to Master (not some "cable select", "single", or "auto" strapping-- I don't trust those). You might need to extract the CD-RW to read the strapping sticker on the top. Hook the CD-RW to the farthest connector of the ATA cable that goes to the SEC IDE port. Your unused slave connector, if present, should be 6 inches back from the CD-RW (meaning, make sure your IDE cable isn't end-for-end backwards).

Most CD-RW's can use an old-style 40-pin cable, but yours might need 80-pin. It shouldn't matter for CD speeds, but since you've got problems it's something else to consider.

Whatever cable you use, also make sure it's no longer than 18 inches max, which is the max IDE spec (though longer cables will sometimes work, sort of).
Unfortunately, secondary IDE seems to no longer be working.
Not sure what you mean by "no longer working". Do you mean you can't boot from it, or do you mean that after you boot, the CD-RW isn't visible in Device Manager and the O/S hasn't assigned it a drive letter?

Since you have both a DVD and CD-RW, you will also want to check the BIOS setup screen "Boot"- "CD ROM Devices" menu. This is a menu which should appear when you have >1 CDROM type devices connected. Under this there will be two choices: DVD and CD. I think you use +/- to toggle these choices between "1st Drive" and "2nd Drive". Choose which drive you want to be able to boot CD's from when needed, and list that drive as "1st Drive"; any other drive(s) will be usable under the O/S, but not for booting off a CD. The CDROM drive you chose for "1st Drive" then becomes the drive you will be allowed to position within your "Boot Device Priority" list, and I like putting the CD at the top of that order.

One other thing I ought to mention about your flaky CD-RW is that you should make sure you have applied the Intel Chipset Software Installation Utility, because the ICH5R chip on your mobo includes ATA/IDE support, which all has to be set up correctly for your attached devices to be properly managed.

-clintfan
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top