Tech Support Forum banner

Overlapping errors and a dead hard drive.

1882 Views 17 Replies 2 Participants Last post by  EnkeiRC5
Greetings ladies and gentlemen, I am brand new to this site. I have chosen to sign up because I have encountered a tremendously annoying issue with my girlfriend's hard-drive. Let me tell you the tale...

Twas a rainy afternoon as I sat beside my girlfriend as she surfed the web. She is an aspiring photographer, and she kept thousands upon thousands of her pictures on a 320GB Western Digital MyBook external hard drive attached to her HP laptop. The drive was about two years old. There was also around 20GB of music on it as well. She opened "My Computer", and discovered the hard drive was no longer appearing there. I suggested she open up "Disk Management", but it wouldn't appear there either. The operating system she uses is Windows 7 Ultimate 64-bit. I told her I'd bring it home and hopefully discover the issue.

I plugged it into my desktop computer, with the very same operating system as she, and saw that it was not showing up under "My computer". Her mother had recently installed a power-thirsty AC unit, and I thought maybe it blew the drive. So I removed the SATA hard drive out of its external fixture, therefore removing the USB/Power requirement. I plugged it in alongside my Western Digital 1TB drive inside my computer.. But I ran into a very bizzare issue...

I can't open mmc.exe. I get the following error message. "The application was unable to start correctly (0xc0000142). Click OK to close the application." Since I can't open mmc.exe, I can't view the drive in "Disk Management". Re-formatting my drive wasn't an option, So i decided to check if BIOS was recognizing the drive. I tried to boot ino BIOS, but it just says "Please Wait..." And never enters. I let it sit for my 8-hour shift at work. It doesn't move. After this, I installed various recovery freeware applications, but none of them saw the drive. Baffled, I removed her drive from my PC, and again tried to access BIOS. Instantly, I was in. It seems as if I'm completely unable to enter BIOS with her hard drive plugged into my computer. Very strange. I know the drive is not completely dead, because I hear it spinning when I plug the power into it.

It is crucial to recover those pictures. I know I sound like a crazy mother who wants her son's birthday pictures back, but it would really mean alot to her. She has years worth of photography on that drive :/

Does anyone dare suggest a solution to this issue? It seems as if I'm left with zero options. No BIOS. No Disk Management. No nothing.
See less See more
Not open for further replies.
1 - 18 of 18 Posts
Can you feel the drive spin up? Is it making any noise? Not found in BIOS connected directly usually indicates a physical issue, What is the model number of the actual drive? (WD#########-######)
Hey, it's a WD3200AAVS-00ZTB0. And yes, I do feel it spinning. But the reason I can't see it in BIOS is because my computer won't go into BIOS when I have the drive attached. For all I know, it may show up. The only way for me to actually get into BIOS, is when the drive is unplugged. Just for kicks, I got into BIOS and then I plugged in the SATA data/power wires. It spooled up, and BIOS said "Detected new device, please reboot." But once I rebooted, it once again wouldn't load BIOS. It just says "Please wait...", and never enters.
You may well have a power issue, post a clear closeup picture of the component side of the drive circuit board. Not allowing the BIOS to open may indicate a load on the 5 VDC leg.
If I understand you correctly, you'd like me to take a clear photo of the bottom of her hard drive for you to examine? I can do that if that's what you'd like.


I have the same brand external hard drive as my girlfriend, but it's a 500GB rather than her 320GB. It's connected to a USB hub. Last night I unplugged the USB hub from the back of my PC, and plugged it back in. Immediately Windows said "A device has malfunctioned". And now my hard drive won't shop up either. It's very ironic how they both broke days apart from each other. That really says something about WD. Hopefully my 1TB internal drive doesn't die in a year also. And as far as my drive goes, (It's still attached via USB), BIOS does not see it. I look at the installed USB devices, and the hard drive is not there.
Yes, witht he drive removed from teh enclosure, the Printed Circuit board on the drive, but we need a pic of the components side of the board. You may need to remove the board from the bottom of the drive with the torx screws through the green board, it will then simply lift off the body of the drive.

I posted both sides of the circuit board.
See less See more
OK so this board is one that pretty much kills any chance of a DIY pc board swap. The adaptives, code unique to each particlualr drive, are in a ROM area inside th MCU( the large Marvel chio with the big M on it.
In teh top picture, toward the lower left corner of the board are two components marked D3 and D4. These are teh transient voltage surpression Diodes. Their purpose in life is to protect more sensitive components from voltage spike by conducting all current to ground when their threshold voltage is reached. This threshold is generally only a few tenths of a volt over teh circuits normal level, a TVS on the 5 VDC line may have a threshold of 5.5 - 5.8 volts. Normally when the spike is sensed, the diode conducts the current direct to the ground and when the spike dissipates, they return to normal function. If the spike is too large, then the diode can fail. Many times that failure is obvious, cracking and scorching, but not in all cases.
The only way to rule this out completely is to test them with a voltmeter in diode test position. They should be open one way, short the other. If shorted in both directions, then teh device has failed. The good news is if it fails, you can simply remove it from teh board, and the drive should function again, allowing you to copy out your data. The downside is without that TVS, your basic protection is gone, and another spike will likely fry the smooth motor controller chip, as well as the preamp inside the drive on the head stack. In other words, this is an acceptable way to run the drive long enough to get your data, it is not a long term fix to the problem. Also, removing the Diode will void the warranty on the drive. If it is failed tho, it usually gets your data back.
See less See more
Ok, I see the D3 and D4 diodes. How would I go about testing them with a multimeter?
Sorry, for some reason I couldn't find an "edit" option for my last post. But I see three small diodes in the bottom left corner. Two laying horizontal, with what looks like an "O" on them. And one vertical with nothing on it. Which diodes are you talking about?
The ones witht he 0 on them are 0 ohm resistors, basically acting like a fuse. D3 and D4 are immediately below the silscreened D3 and D4. You would test them in circuit, unpwered using a multimeter with diode test position. They should be short ( beep if the meter has audible ) one direction and open ( no beep ) in the other. if they are shorted in both directions, then it is defective.
I tested both diodes. They both acted the same. Beeped one way, and didn't beep the other way. Whats that mean?
That means they are fine, that is not the issues. This could be a firmware failure, it is common on these boarsds, not excessively but it is always one place to look. You would need to replace the PCB withan exact match, and have someone move the rom code from the MCU chip of the old board tot he new board. There are several vendors who will match and provide this service, Most seem to be the cost of the board ( $35 - $60 ) and usually lke $50 to move the code. Again no guarantee that is what it is, but about the only other alternative to try at home if the drive is not detected in BIOS..
By ROM code, you mean that large "M" chip? What would have to be transferred? (And thanks a million for all your help so far). Also.. Do you think local electronic retailers like Best Buy or Staples would provide such a service?
No, this is beyond computer centers or techs, HDs are a specialty. There is code written to the eeprom portion of that chip that must be downloaded from the patient board, and will overwrite the code in the donor board, that is assuming you have a good match on the donor board. This requires more than just the same model number, the firmware rev, PCB nos country of origin and date code must also make a match. This is definitely a specialty area.
So if I'm thinking of going and buying an idential drive for 100 bucks, I can't switch over the PCB?
Nope.... not only that the identical drive , by model number, does not even ensure a compatible drive if you do move the rom code. The ROM contains adaptive information that is specific to each individual hard drive, so that information must exist. It is theoretically possible to find a drive with similar enough parameters that it might work, or it might work at reduced efficiency, but unlike many other devices, each HD is unique, and the ROM code handles those unique differences.
Raptor, thank you very much for all the help you've given me so far. But I'm not aware of any local data recovery businesses unfortunately. Just for the hell of it, I plugged my external hard drive into a Windows Vista PC that belonged to my father. It appeared in My Computer, and I was able to recover everything. But I can't say the same for my girlfriends. I re-assembled it inside its external enlosure, and plugged it in. After about ten minutes it said "Drive is installed and ready to use". But it didn't appear in My Computer. It did however show up under Disk Management. It said...

"Disk 5" - Unknown. Not initialized. Now, I understand initializing the disk will format it and erase everything, correct? Foolishly, I tried it anyways, and it said it was unable to initialize it.

I feel like I'm getting somewhere. Any ideas?

Edit: I installed a couple recovery programs, but they didn't detect the drive at all.
1 - 18 of 18 Posts
Not open for further replies.