Tech Support Forum banner

Odd RAID problem...

1076 Views 15 Replies 4 Participants Last post by  PYFighter2000
Ok I have a gigabyte GA-M61P-S3 motherboard, and a Raptor drive and 2 WD 640gb drives. The two WD drives were set up into a RAID and I had Windows XP set up on my Raptor. Well my raptor died on me so I had to install windows on a new hard drive. Well now when I boot it back up my RAID is not working kind of. This is what happens.

So If I turn the raid function under my bios OFF, the computer will not boot to windows, So then if I turn it to ON and set the SATA to enable/disable for the RAID, I have to turn the Raptor on and the rest off for it to boot to windows, but then it gives me the raid unable to function screen. So now it gets weird, if I turn the raptor to OFF and the two WD to ON like it should be, windows will not load, and under the BIOS it will not show the Raptor drive, it only shows the two WD drives. So I have no idea of the problem, and I have tried updating my RAID drivers, but I am not sure I did it correctly. It has been a while since I got the raid working and I remember it was somewhat of a hassle. I just need some way to get the info off of the raid. So ANY help would be great... thanks

Not open for further replies.
1 - 16 of 16 Posts
Hmmm, I do not know, any way that I can troubleshoot that? See when I was troubleshooting my bad hard drive I was unlplugging everything to try and find what hardware was conflicting. So now I do not know if everything is plugged into the SAME ports as before, and I DID have to switch the cables on my hard drives for the RAID to even start working, but like I said if the raid is working then the Raptor is not even recognized by the BIOS
Is it raid 0 or raid1? Is the Raptor you are talking about the new drive where you installed Windows? Exactly what ports is each drive attached to and how are those ports configured in BIOS? What version of windows and what service pack?
Alrighty then, it is a RAID 0 array, and the Raptor is the new hard drive that windows is on, so when I get the array working then windows wont load I assume because the Raptor is not recognized, it stops loading after the "DMS VERIFIED"? I think, bios post. Just sits there with a blinking cursor. Ok and the WD are in ports 1 and 2 and the Raptor is in 0 and then there is a DVD Drive in port 3. There are only 4 SATAII ports. I am not sure what you mean by how they are configured in BIOS. I am running Windows XP with no service packs installed (just trying to get my info and then going to install windows7). Not sure if it would really be windows causing the problem....
Can you configure the individual ports? It's almost sounding like when you enable the raid, sata0 is being included as on of the array disks.
Hmmm not EXACTLY sure I know what you mean by configuring the individual ports... BUT, when I configure the raid under the bios, I have to turn the RAID function to enabled for windows to load anyways. And I can turn each port to Enabled/Disabled. So you would think I should turn 1 and 2 to enabled for RAID functionality and then ports 0 and 3 to disabled. But when I do it does not recognize the Raptor on startup... It is like for some reason it only loads the drives that are turned to Enabled?
Ok, I installed SP2 for xp. I also have some other info. Right now with Windows working this is how I have my settings. There are only two Drives that are recognized right now under bios. IDE Channel 2 Master which is the Raptor, and IDE Channel 5 Master which is the DVD Player.

Under the RAID configuration, the Raid is enabled, and NV SATA1 Primary is Disabled and NV SATA2 Secondary is Disabled.

If I open up the RAID page? It shows one array that is failed. it is called Array 2. Raid mode is Spanning, striping width is 2 and striping block is 64k. If you explore that array it lists only one hard drive. Port=2.0 Index=0 Disk Model= WDC WD 640 Capacity=596.
So should it not show two drives there? I do not understand why only one of them would show up unless the drives might be plugged into the wrong ports?
Shameless bump, I have not gotten it working yet so anybody got any ideas?
can u put 2 new blank hard drives and try to rebuild the RAID and check. IF that works then we can think of a different way to recover the data from your old hard drive
Hmmm... well i do not have two extra hard drives just laying around so I do not think that is an option at the moment...
Ok I did some troubleshooting and this is what I got. Ok so there are two identical hard drives (duh!) so I will refer to them as 1 and 2.

OK, so if I enable the raid, whenever 1 is enabled, it will detect the array, but will have an error and seems like it does not detect the other hard drive. I have tried changing the port that the other drive is plugged into to every other port, not sure if it matters... Do they have to be in the same ports as they originally were?

Ok so if I enable ONLY 2, it will act as if the array does not exist. So I assume that it detects the array through the info on 1...

So basically if 1 is enabled it only seems like it is the only thing it recongnizes... could the array be toast? Perhaps 2 has an error and it cannot detect it?

Any other tests I could do or any ideas somebody??? Thanks
Try with both enabled in BIOS and the boot disk set to IDE mode. The raid signature is probably only on the first disk. In most controllers the disks need to be on the port they were originally attached.
Ok well I tried every possible combination of those two being plugged into the ports. There are only 4 ports. Nothing works. It seems like it just does not detect the raid on 2. Perhaps it is just toast because I am out of ideas...
Run the HD manufacturer's diagnostics on each drive to make sure there is not a physical issue with one of the drives, start with #2 since it is the most suspect.
Alright ran the diagnostics on both drives and everything checks out... still not working and still out of ideas.... help?
1 - 16 of 16 Posts
Not open for further replies.