Tech Support Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Plugged in nvme enclosure with 2TB Samsung 980 Pro into my PC, nothing happens. Device Manager shows the following:

r/computer_help - Nvme enclosure not working on my PC, working on others PCs, driver error?
But in the driver tab, it states a driver is installed:

r/computer_help - Nvme enclosure not working on my PC, working on others PCs, driver error?
If I attempt to update driver, I get the following:

r/computer_help - Nvme enclosure not working on my PC, working on others PCs, driver error?
If I search for updated drivers on Windows Update:

r/computer_help - Nvme enclosure not working on my PC, working on others PCs, driver error?
If I unplug this from my PC and plug it into my Win 10 laptop or my colleagues Win 10 PC, it works perfectly, appears in disk management and can be initialised then used, so it's not the enclosure or the drive that's the problem. I've also tried another enclosure from a different brand, and it had the exact same errors on my PC, but worked on other Win 10 PCs.
Manufacturer of the enclosure does not have drivers, as the device is plug and play, and works on my Win 10 laptop and a friends Win 10 Desktop PC.
The drive does not appear in Disk Management.
I have attempted the following:
Restart PC - No change
Update driver - It states the best drivers for your device are already installed
Uninstall Device - Stays on Uninstall device for many hours, nothing ever actually happens.
Reset PC, reinstall Win 10 - No change
Different USB port - Have tried all of them on mobo, front of PC and even a powered USB hub.
Different USB cable - Have tried many, no change.
SFC /scannow - Files repaired but no change
Update USB and other drivers via MSI (motherboard manufacturer) driver updater - Drivers updated, no change.
Here is my system information:

r/computer_help - Nvme enclosure not working on my PC, working on others PCs, driver error?
Please help...
 
1 - 2 of 2 Posts
Top