Tech Support banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Dear all,

Yes its that black and white TV output problem....
I have a Compaq presario with AMD 3200+ processor and Nvidia 6600GT PC-X card.
When connecting to the TV via either composite or Svideo I get a black and white picture. Even if I set the output to be Pal-I (correct for UK). The problem *appears* to be somewhere in the Nvidia drivers, or in some weird combination of XP (service pack 2) and the drivers. When I start the computer the TV output is in colour (or color if you prefer). It stays in colour until the blue XP welcome screen is displayed where apon it goes black and white.
I am guessing that windows has not loaded its drivers before this point.

So has anyone managed to solve this problem?
It is not the cable, and as far as I can tell it is not the video format.

Nvidia drivers are currently 71.24
Hope someone can help

Regards

John.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Additional information...
I have now updated the driver to 78.01 - no change tv output is still black and white after windows loads drivers.
However I have noticed that control panel is insisting that the 2nd display is a default monitor, rather than a TV. I have tried and failed to get it to install a tv driver. Add new hardware does not appear to allow this. In windows 98 there was a tv driver.
Odd... Anybody any thoughts? I am well and truly stuck. My version of windows in XP SP2, not the media version. Hope this is not the problem...

John.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Compumaniac12 said:
black and white... sounds like a signal distortion, try to straighten the cable out, and make sure its not too long.
Sorry don't work. As I said in my first post; I have a colour output when the PC is first turned on and right up till the time windows loads its drivers. Then it goes black and white, so I am guessing there is something stuffed with them. What I don't know is how to solve this.
 

·
Registered
Joined
·
27 Posts
cogvos said:
So has anyone managed to solve this problem?
yup:
- go to nvidia control panel
- go to nView display settings
- click on the tv in the big gray box (provided you have it already set to "Clone")
- click the device setting button, then choose select tv format, then choose advanced
- under "Video Output Format" select composit video-out

That should solve your problem, i had the exact same problem and figured that out on my own, yet im still having issues playing media on my tv, the tv display will NOT display any videos... be it windows media player or a dvd software the video image will be a blank/black screen on the tv but play fine on my monitor :(
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
black and white video on Nvidia cards - the saga continues

Many thanx Icedragn43,

OK the saga continues....

I have now removed all nvidia drivers, display and WDM and re-installed, a number of posts elsewhere suggested that there can be problems if you simply overwrite nvidia drivers rather than removing them. Sadly Svideo is still black and white after windows loads its extended drivers, but composite works.
I'm not the only person with this problem, a quick check of net shows that it's cropping up all over and only with Nvida cards (?).
I can't believe that it is a cabling issue, unless the windows drivers are somehow changing the phase of the croma signal slightly so the TV can't pick it up. The cable works until windows loads its drivers.

For those of you stuck with no video output here is a partial solution.
Set the displays to be Duelview (not clone).
Start your video playing software.
Drag the video softwares video onto the tv screen. Just grab the top bar and pull it off the monitor and it will appear on the tv.
Start your video - playback is now on the tv.

*But* (you could feel that comming)
You may find (as I do) that you cannot watch DVD playback this way. On my pc video streams from the hard drive fine. Video from the dvd player does not. The playback brightness varies randomly and there are occational horizontal lines on it. Wierd.

So I can now get colour via a composite cable.
I cannot get colour via an SVHS cable after windows loads but I can before.
I can play video off the hard drive, but not from the dvd drive.

Any ideas?

John.
 

·
Registered
Joined
·
2 Posts
I am currently having the same problem with my video card not display color on the television in the same way you were, although I did try the solution listed here it didn't work for me and I'm still getting black and white, any other suggestions?
 

·
Registered
Joined
·
6 Posts
solutions ??

cogvos said:
Dear all,

Yes its that black and white TV output problem....
I have a Compaq presario with AMD 3200+ processor and Nvidia 6600GT PC-X card.
When connecting to the TV via either composite or Svideo I get a black and white picture. Even if I set the output to be Pal-I (correct for UK). The problem *appears* to be somewhere in the Nvidia drivers, or in some weird combination of XP (service pack 2) and the drivers. When I start the computer the TV output is in colour (or color if you prefer). It stays in colour until the blue XP welcome screen is displayed where apon it goes black and white.
I am guessing that windows has not loaded its drivers before this point.

So has anyone managed to solve this problem?
It is not the cable, and as far as I can tell it is not the video format.

Nvidia drivers are currently 71.24
Hope someone can help

Regards

John.
Hello from Romania !

Pls inform me if you resolve and how, because I have the same problem, too.
 

·
Registered
Joined
·
1 Posts
As in the post below:

- go to nvidia control panel
- go to nView display settings
- click on the tv in the big gray box (provided you have it already set to "Clone")
- click the device setting button, then choose select tv format, then choose advanced
- under "Video Output Format" select composit video-out

That did not work for me!

However !!!
I left the last step in the above list (leaving it Auto-Select) with:

- click Device Adjustments
- click Restore Defaults (Screen Goes to Color !!!!)
- click Save As, enter "Nick's Fix", click Ok



Also a bug tip for playing quirky video on dual screens.
On my pc switching the TV to/from the left side to the right side in 'Display Properties', 'Settings' allows the video to stream. Why? I just don't know if I care anymore. Switching it back to left side would kill the video from playing. Of course it's not a problem now, and I'm enjoy Netflix on my TV in relation to my display settings for once.

Good luck, Nick
 

·
Registered
Joined
·
1 Posts
Upgrade Drivers = Black and White Output On TV - Problem solved

GeForce FX 5200
Dell Dimension 8300
XP
S-Video>RCA Cable

I upgraded my driver with the latest GeForce package. Result: Color output of "Windows XP" splash screen, then Black and white output. This told me "drivers/software, not hardware (cables, pins etc)

I tried many, many fixes and none of the standard ones worked including. My control panels did not display a choice of NTSC/PAL/S-Video/Composite anywhere.

My fix: Click on every available "restore defaults" option in the NVIDIA control panel, in advanced mode (view menu). When I restored defaults to the last item (Adjust Screen Size and Position), color came on. I have no idea why, but this worked. Problem solved with a simple software fix after hours of trying.
 

·
Registered
Joined
·
29 Posts
Ok this is for anyone still having the problem.
1) go to nvidia control panel
2) Display
3) Adjust desktop color settings
4) select TV
5) go down to "Apply the following enhancements"
6) Digital vibrance: (If it is at 0 then this is the problem) just move the slider up to where you like it.

At least this is what my problem was and it is easyer than doing all the other stuff
Hope this helps you all!
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top