Tech Support banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
:confused:

When I switch on my computer, it 'fires up' then powers down after 1 or 2 seconds. Yesterday it did the same but eventually started. Later in the day I changed the processor, switched the PC back on and it started fine. Now this morning it won't start again. I think(hope) that it is the switch on the case. Anyone got any suggestions other than replacing the case?

I need my PC for work so I need a fast confirmation or answer.

Thanks in advance
 

·
Premium Member
Joined
·
1,611 Posts
welcome to the forums perquaine :D

do you have a heatsink + fan properly mounted on the CPU ? what might be happening is that the heat is not being drawn away from the processor as it should be so it shuts itself off as a precaution...if you have a fan on the heatsink, check if its working properly...can you post more specs. on you system btw....
 

·
Citizen of the world
Joined
·
51,042 Posts
If you've checked all the connections, I'd start with the power supply. Since the processor is just starting up, I wouldn't think overheating in a couple of seconds would be an issue. The ATX switch is a momentary contact switch. Since the switch is sensed enough to start, it's not the switch. Check all connections first...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Non start on switch on

Just to say thanks for the replies. I actually bought a new tower with power supply and it solved my problem!!

It did take a while to transfer my M/B and hardware across though.

hope I can help someone inreturn someday.:winkgrin:
 

·
Premium Member
Joined
·
1,611 Posts
Im glad you have the problem fixed....and yeah, this is the right place to help people and gain some experince while you're doing it ...glad to have you around !!!
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top