Tech Support banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all;

I have been having a heck of a time setting up a wireless network in my home and I think that I finally have it partially solved or otherwise fully troubleshot.

PC1 is XP Home SP2, hard wired to a D-Link DI-624c
PC2 is XP Pro SP2 wireless D-Link adapter.

Both PC's get internet fine, both have unique names, the workgroup name shows on both computers. I can ping each computer and the router by IP adress but not by name. Filesharing is also not possible, and the PC's do not show up as in the same workgroup on either PC.

I was digging around and ran IPconfig /all on PC1 and saw that NetBios over TCP/IP was disabled. I have run through the following 5 times to no avail;
Control Panel - Network Connections - Local Area Connection - Properties - Internet Protocol (TCP/IP) - Properties - General - Advanced - WINS - Enable NetBios over TCP/IP - OK - OK - Close.

Each time I complete the selections and check IPconfig /all and each time it shows: Netbios over Tcpip....Disabled.

Does anyone have an Idea on why this is happening or how I can fix it?

Thanks in advance
 

·
Citizen of the world
Joined
·
51,042 Posts
Try resetting the TCP/IP stack and WINSOCK to installation defaults, reboot, and try again.

TCP/IP stack repair options for use with Windows XP with SP2.

For these commands, Start, Run, CMD to open a command prompt.

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

Reset TCP/IP stack to installation defaults. netsh int ip reset [log_file_name]

Note: the log_file_name needs to be specified, e.g. netsh int ip reset reset.log
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
You are a god. I am not worthy!

Thanks John, that solved it. After a week of trying many diferant things, I should have turned here earlier.

Thanks again.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top