Tech Support banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi guys, I need help on fixing my computer. I have an MSI mobo and I decided to update my bios via its utility software (I know, I'm an idiot), it began installing and then "beepining" and froze or I guess the term is "flashing". I had no choice but to reboot and all I get on it is a blank screen. I know there is some of way of fixing this by downloading the AMIBIOS from the MSI website but their instructions are horribly vague. Need help ASAP.

Can someone please explain all this stuff step by step to me please?

Thanks in advance, please help.
 

·
Registered
Joined
·
1,353 Posts
Hello hyethga187 and Welcome to TSF.

1. Were you having any problems before deciding to upgrade your BIOS? It really isn't a good idea to upgrade BIOS just because there is a newer version.
2. What is the model number of your mobo?(Give complete specs of your computer e.g. make/model of mobo, cpu, ram, etc.)

We'll try and help get your computer going again if possible.
 

·
Registered
Joined
·
2,171 Posts
What motherboard do you have? You might take a look at the "FIX A DAMAGED BIOS BY LOADING IT FROM FLOPPY OR CD" section of this post for info on boot blocks. This page has a good explanation of the AMI BIOS recovery process. If all else fails you can always send your BIOS chip to one of the eBay reprogramming services to get it working again.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
1) No I wasn't experiencing probs. It was typical hubris on my part and I have found out that there are many others like me who fell for MSI update utility. A typical average knowledge on computer person like me fell for it. I know I was stupid but I appreciate any help.

My specs:

128meg Geforce 4TI 4800SE
Intel Pentium IV 2.4ghtz
1 gig of RAM
Windows XP SP2

Mobo:

MSI 865PE Neo-2

I bought it about two years ago.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top