Tech Support banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi there this is my first post looks like a great forum!

Right my problem is with my network ,the way i am setup is by using a router/modem which my dsl is plugged into and then the router plugs into the following
1, "downstairs" pc through a cable
2,"Upstairs" pc through a cable
3,"Xbox" through cable
i used the home network wizard on both pc's for me to share files.
i set the downstairs one as connecting direct to the internet and the upstairs one as connecting through another computer
Everything was working fine internet/file sharing then one day the upstairs pc just stopped no internet or file sharing.(downstairs and xbox still ok)
I have tried a few things like :
re-doing network wizard,
tested cable(working fine),
tried different network card(No luck)

The connection bubble comes on saying lan connected but i never receive any packets but i do get given an ip address
Sorry for going on but im totally stumped!
Hope someone has some ideas as i am not too clued up on networking
Cheers steve
 

·
Citizen of the world
Joined
·
51,041 Posts
Open a DOS window and type:

IPCONFIG /ALL >C:\RESULT.TXT

Open C:\RESULT.TXT with Notepad and copy/paste the entire results here.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Hi thanks for the replys!
Keymaker i tried that repair and it came up saying failed to repair
heres the results from the ipconfig Johnwill:

Windows IP Configuration



Host Name . . . . . . . . . . . . : UPSTAIRS

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Mixed

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No



Ethernet adapter Local Area Connection 5:



Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet NIC #3

Physical Address. . . . . . . . . : 00-30-84-89-6B-9B

Dhcp Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

Autoconfiguration IP Address. . . : 169.254.12.47

Subnet Mask . . . . . . . . . . . : 255.255.0.0

Default Gateway . . . . . . . . . :

Now i know theres no default gateway listed i have tried entering the routers ip manually but still no luck ,i am unable to ping the router or see the routers connection screen like i can downstairs
 

·
Citizen of the world
Joined
·
51,041 Posts
OK, the indications are that you have lost the connection to the router. the 169.254.x.x address is the autoconfiguration address that Windows assigns when it can't find a DHCP server. That indicates either you have a physical connection issue, or a damaged TCP/IP stack.

If you can move the computer next to the router, it might be instructive to try a short cable and see if it's a physical connectivity issue. If not, let's try these:

For XP-SP2, try this:

TCP/IP stack repair options for use with Windows XP with SP2.

For these commands, Start, Run, CMD to open a command prompt.

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

Reset TCP/IP stack to installation defaults. netsh int ip reset [log_file_name]

Note: the log_file_name needs to be specified, e.g. netsh int ip reset reset.log

If it's not XP-SP2, here's some other solutions.

Automated WINSOCK Fix for XP

Automated WINSOCK Fix all Windows Versions
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Hi, JohnWill
Thanks for your advise i tried that winsock fix but no help.
But what i have just tried is taking the router upstairs with a short cable and plugged that in to see if i could connect to the router and low and behold i could and was given a ip address!
I know what your going to say,the cables no good but yesterday i took my xbox upstairs and plugged that into the long cable and that worked fine it got a ip address and went on xbox live ok.
So how come it seems to work on that but not on this
Hope you might be able to make some sense of it
cheers
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
hi
Back again!
I did what you did and brought the computer downstairs and used a short cable and it worked ok.
So yep it is the cable,i was so sure that it wasnt with it working on the the xbox and i do get a connection bubble on both pc's which i thought i wouldn't if it was a faulty cable.
Thanks for your help anyway.
P.s the internet worked ok but i couldnt access the shared folders i congfigured the firewall so it wasn't that.
Do you know any commen problems that prevent file sharing?
 

·
Citizen of the world
Joined
·
51,041 Posts
Checklist for networking Windows Machines with TCP/IP
-----------------------------------------------------
- PCs which are not XP must have TCP/IP installed.
- Each PC must have a unique computer name.
- Each PC must have a network share defined.
- ALL NICS must be on the same subnet (e.g. IP 192.168.0.* subnet mask 255.255.255.0).
- XP PCs must have Netbios over TCP/IP enabled (only essential for XP to talk to W9X PCs).
- MS Client and file & printer sharing must be enabled on each machine.
- All NICs must have their node type = anything except p-node (peer to peer, or point-point).
* To check, open a command prompt and type IPCONFIG /ALL.
- XP's ICF firewall is permanently disabled. (Only necessary for pre XP SP2).
- All 3rd party firewalls are disabled, uninstalled and deleted (until connection is working).
- PCs have the same workgroup (helps, but not essential for XP/2K, necessary for 9X/ME).

Allow 15 mins after rebooting a PC for that PC to appear in the workgroup, or
for it to see all other PCs. Or you can search for the PC by its computer name.


Additional things to check if you still have problems:
-----------------------------------------------------
- Check your Services are Started on all PCs: Workstation, Server, TCP/IP Netbios helper, Computer Browser.
- XP gives access to its shares via the Net Guest Account. (Note, not the same as the local guest account in user accounts which should be off). Net Guest Account is enabled by default in XP, but to check it, open a command prompt and type: NET USER GUEST
Should return a line with 'Account active yes'.


Check XP Security policies:
--------------------------
- Access this computer from the network: add guest
- Deny logon locally: remove guest
- Network access:Sharing and security model... -> Guest only
- Deny access to this computer from the network-> check Guest is not here.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top