Tech Support banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey,

Just trying to install the X11 version of naim, I have un-tar'd and run configure and I get the following error... any ideas?

checking for wresize in -lncurses... no
checking for wresize in -lcurses... no
configure: error: unable to find a curses library -- FATAL

I thought the curses library came as part of a unix based OS?
 

·
Registered
Joined
·
711 Posts
If I remember correctly for some cracked out reason Mandrake doesn't include the curses lib, you can get it though and install it :) go to www.rpmfind.net and do a search, if you can't find it, I'll build you an RPM of it :)

Drew
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
I have done a search on the site and a couple of the mirrors, it is unable to find the library. Any other ideas?
 

·
Registered
Joined
·
711 Posts
I'm going to build you an RPM, I'm slightly inebriated at the moment, so its going to be the morning before I get it done but I'll get 'er for you :)
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
I found and downloaded what I think is what I was looking for... maybe.

Its called ncurses-5.3 and seems to be mainly source code and librarys, I tried ./configure and it completes with one warning (not sure if its important but its not fatal):

-------------------
checking for builtin bool type... no
checking for size of bool... unknown
configure: WARNING: Assuming unsigned for type of bool
checking for special defines needed for etip.h... none
checking if g++ accepts parameter initialization... no
-------------------

I still get the error I reported in my first post when I try to ./configure naim
 

·
Registered
Joined
·
711 Posts
if its not fatal then you should be ok, as long as it doesn't come out with an Exit status error code like 1 ... which is what I got before i came to work when I tried to compile it ;) I was gonna hack around it tonight when I get off work at midnight
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top