Tech Support banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
i've been trying to install this new USB 2.0 card on my computer. the driver CD has soooooo many drivers for different chipsets. i found out what my chipset is and opened the right folder, but there's no driver for windows xp sp2, only sp1. im getting frustrated then i see this readme file on installing it on xp.

ok, so it says open up the device manager. i do and......... its empty! ok, not completely empty, there is one icon, my computer. and thats it. i dont know whats wrong. ive opened up the device manager before and it was fully populated.

oh, AND there is not plus sign on the left of my computer icon to open it and display whats there.

whats happening? how do i fix this? coz these USB 2.0 ports are driving me half crazy!
 

·
TSF Team Emeritus, Microsoft Support
Joined
·
15,478 Posts
This issue seems to be related to missing permissions in the registry.

You must use regedt32.exe in Windows 2000/XP AND be logged on as the local administrator to perform this task:

1. Go to Start, Run, and enter regedt32 and select OK
2. Maximize the HKEY_LOCAL_MACHINE window.
3. Scroll down to SYSTEM\CurrentControlSet\Enum
4. With Enum selected click the Security option from the Top of the screen then the Permissions menu.

Note: At this point you will probably notice there are no permissions on this key.

5. Click Add
6. Add the group Everyone and the user SYSTEM
7. Select Everyone and check only the Read box
8. Select SYSTEM and check Full Control
9. Click the Advanced button at the bottom of the window.
10. On the Advanced window check Reset permissions on all child objects
11. Click OK
12. On the warning window click Yes
13. Close REGEDT32

Re-boot the system if necessary and then check the device manager to see if everything is showing now.

If not, then Click start, select run, type services.msc in the run box, hit your enter key.

Look in the list of services for Plug and Play. If plug and play is turned off, device manager won't list any devices and of course, most of your devices like a printer connected to USB wont work.

If it is turned off, right click it and select start.

http://www.askmarvin.ca/forums/index.php?showtopic=1790
 

·
Registered
Joined
·
66 Posts
Discussion Starter #3
yay! thanks!! it worked! if i want to install a newer driver for my USB 2.0 ports, which do i do it to? the USB Root Hub, the VIA USB Enhanced Host Controller or VIA Rev 5 or later USB Universal Host Controller?
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top