Tech Support Forum banner
Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have Windows 2000 Professional. I just got a Cowon D2 MP3 player. When I plugged the MP3 player into my computer, Windows reported that it had found new hardware. I then followed the directions to install the driver. Windows couldn't find a driver on my machine, but the MP3 came with a CD. I specified the CD as the location and Windows installed a driver from there. I didn't write down the name of the driver it installed. Ok so far. Windows Explorer shows the MP3 as if it were a hard drive, as it is supposed to.

Following the D2's installation instructions, I attempted to update the D2's firmware by copying the specified firmware file to the MP3 player. That appeared to work fine. After that, the instructions say to unplug the device from the computer. Unfortunately, I did not know to "stop" the device first. After unplugging the D2, I got the message from Windows about having unplugged something without stopping it. (I did see on the pcworld myth page that unplugging without stopping isn't as bad as reported, as long as the device isn't doing anything at the time. Since my file copy had completed, I don't think it was doing anything.)

In the mean time, the D2 player seemed to do what the instructions said it would for step one of the firmware install. Next step was to plug the device back in to the computer and copy another file to it. Unfortunately, when I plugged the MP3 in, it didn't show up in Windows Explorer any more.

Windows popped up the window saying new hardware was found, but attempts to install the driver fail. Per the PCWorld myth page, I tried unplugging the device, waiting a few minutes and then plugging it back in. I also tried rebooting the computer. No difference. Device manager shows an exclamation on the USB device, driver installations report failure, and the D2 does not appear in Windows Explorer.

With the MP3 not plugged in, the device manager wanted to install driver c:\winnt\inf\usb.inf It said that is better than the driver currently installed. I said ok, and now device manager show the device as being ok instead of showing the exclamation icon, but I'm sure it's now got the wrong driver. My guess is that the partial firmware install is keeping Windows from understanding what driver to use when the D2 is connected to the computer.

I searched the CD that came with the D2 MP3 player for files with extension .inf I found a file named teleumss.inf

I'm thinking that I should use device manager to reinstall the driver, and force it to use the driver off of the CD that came with the player (teleumss.inf). I tried doing that with the D3 MP3 player not plugged in, but windows keeps forcing the install to c:\winnt\inf\usb.inf even when I specify the exact location of the inf file on the CD.

Should I plug in the MP3 player and do an "update" of the driver, specifying the location of the inf file on the CD?

What else can you suggest for recovering from this? Obviously, I'm no hardware geek, since I didn't even know about stopping devices before unplugging them. Any help you can provide would be greatly appreciated.

Thank you.
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top