Tech Support Forum banner

Missing Windows Installer on Win 7 64 bit

7557 Views 6 Replies 3 Participants Last post by  doxie56
I have Win 7 Home Premium 64 bit. I ran several programs recommended by a tech on to help speed up my computer. However, somehow my Windows Installer is no longer working. I get a message when trying to re-download CNET Tech Tracker, "Unable to initialize installer GUI".

The programs I installed and ran were:

Advanced SystemCare

It also had me adjust visual affects and make some adjustments on Indexing Options. It was after I followed the instructions and ran the above programs that I discovered I can't download most files due to an apparent missing Windows Installer file. I've tried finding out how to re-install this file only to realize that none of the files listed on the Microsoft sites is for my version of Windows.

This is the link to the site and info: Several Easy Steps to Boost Your Computer's Speed

After spending almost the entire night trying to repair Windows with my disk (couldn't due to corrupted files in C drive) and running the Win programs to analyze and (hopefully) repair the drive... all to no avail.

PLEASE HELP! :banghead:
Not open for further replies.
1 - 4 of 7 Posts
I tried to restore first; but as usual, Windows Restore rarely, if ever, works. I then tried using the command prompt as admin. This got me a message that follows:

"Windows Resource Protection found corrupt files but was unable to fix some of them.
Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example

I tried to access but received message "Access is denied".

I have tried to scan and repair the drive to no avail. Of course, using the Windows 7 cd to repair Windows wouldn't work due to the corrupt files. I have no idea where to go from here other than a clean install, which would mean losing everything since I don't have another drive large enough to use for a backup.

I also just scanned the hard drive and it said there were no errors, it also included the following in the report:

"The master file table's (MFT) BITMAP attribute is incorrect.
The Volume Bitmap is incorrect."

How do I fix these?
Actually, I first trying right-clicking the drive in question and clicking the option to scan/fix the hard drive. I wondered why it didn't appear to be Windows that was scanning. It turned out to be Advanced SystemCare that was doing the scanning and claiming I had errors on the hard drive that couldn't be fixed. So, I scanned with the Windows scan disk utility, which found NO errors. Surprise!

Last night I finally tried to fix Windows using my cd. The only problem I had was that it said iTunes may not work afterward. (I haven't yet checked; but it's easy to dl again and move my music from the folders on my hd to the new dl of iTunes. No biggie there. Of course, the disc ran all night and finally finished around 1 p.m. today. Then when I put in my Win7 key it said my key could be bogus and isn't a key for the U.S. So I called MS and got a very nice and helpful tech who walked me through some steps to get the set of 9? numbers, then gave me new sets to type in. I now have back my authorized Win 7... whew! My biggest regret is that I didn't write down the sets of numbers he gave me for future reference.

Thank you for your help and suggestions. I have now removed Ccleaner and Advanced System Care from my computer as one of them is the culprit in erasing my Windows Downloader. From now on I don't dl ANY suggested "helpful" programs to make my system run faster without coming here first and getting the right advice.

With that said, can you recommend a program that cleans up the junk without destroying my Windows files and/or crashing my system? For now I have only 1 gig of ram and find it takes awhile to load my browser. (I DID notice my browser loading within a few seconds after following the instructions on Instructables as per the link in my first email and would love to see that happen again!) I'm open to suggestions.

Thanks again!
See less See more
1 - 4 of 7 Posts
Not open for further replies.