Tech Support Forum banner
Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
The icons for almost every file don't look right. Empty folders look like unknown files and EXE's with no embedded icon display the same way (it doesn't have the green window icon thing). Also, some icons have double pictures on them, meaning there is a notepad.exe picture over an "unknown file" picture on the same file.

Does anyone know how to fix this?
(If you need more info, ask)
 

·
Freelance
Joined
·
886 Posts
Hey Wilkua

You may have to rebuild the iconcache


1. Unhide the system files. (Control Panel\Appearance and Personalization\Folder Options - View tab and show hidden files)
2. Click Start button and select Computer.
3. Navigate to C:\Users\(your username)\AppData\Local
4. Right click on IconCache.db and click Delete.
5. Click Yes to confirm the deletion.
6. Close the window.
7. Empty the Recycle Bin.
8. Restart the computer.
9. Navigate back to C:\Users\(your username)\AppData\Local

You will notice the Size of the IconCache.db file is smaller, and the Date Modified is now the current date.

You may need a couple of restarts before the file re-appears

Regards




Craig
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #3 ·
I deleted the file but it just came back the same. Then I shredded the file using Spybot: Search & Destroy's file shredder. When it cam back it went from 1.92 megs to 1.51 megs and the problem still exists.
 

·
Freelance
Joined
·
886 Posts
Ok you can try this

1. Click start

2. Control Panel\Appearance and Personalization\Adjust Screen Resolution

3. From the Colours drop down menu select 16bit if its currently set to 32bit and vice versa

4. Select Apply and Ok

5. Restart your PC

6. Click start

7. Control Panel\Appearance and Personalization\Adjust Screen Resolution

8. Reset the Colours option back to what it was previously set to and select Apply and Ok

9. Restart your PC again

It should readjust your folders icons

Regards




Craig
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #5 ·
This tactic didn't work either. If you need some more information then what I gave you in the first post then let me know.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #6 ·
Is there a program in vista like the "File Types" tab in the Folder Options like in XP? If I had that, I could have fixed this problem a long time ago.
 

·
Freelance
Joined
·
886 Posts
Hey

I apologise for my absence, the only other thing i can think of to fix this without re-installing your system is tweaking the registry or trying to restore your system back to before this originally occured

The registry tweak is attached

It will:

  • Reset settings on Folder Types and Views
  • Disable automatic folder template type recovery
  • Increase BagMRU size (which store folder settings) to 10000

If you are unsure about this tweak then you can open with notepad and see the information and keys it contains.

***Always perform a Backup before tweaking your registry

Regards




Craig
 

Attachments

1 - 9 of 9 Posts
Status
Not open for further replies.
Top