Tech Support Forum banner
Not open for further replies.
1 - 1 of 1 Posts

· Registered
1,234 Posts
Discussion Starter · #1 ·
My son has been moaning at me for ages to do something about his PC. He had a few niggling problems but the main issue was the size and speed of his hard drives. He has one 500gb C: and one 2TB D drive for storage. Neither are particularly quick and he's often left waiting for things to copy or load before he can move work. He does a lot of music 'production stuff' and video editing amongst other things, and although he has a Mac pro for a lot of this stuff he tends to use each computer for specific tasks. Anyway, I decided on a Sandisk X400 512GB M.2 2280 SSD in the end and at the weekend set about installing it.

His original drive was using legacy boot ROM and my intention was to change it to UEFI (which the M.2 Drive needs to boot) so I wouldn't have to install from scratch. His upgraded to Windows 10 was from 7, and although in such cases I would rather have done a fresh install the I found the details around fresh installs somewhat murky, with some indications as long as it was installed on prior machine a fresh install would be fine, while other sources claiming this only works if you have a MS account to link it to. I figured for the time being, changing the drive from MBR to GPT then using UEFI would be easiest and least time consuming. Boy was I wrong. Bare in mind I have done this successfully in the past, but in this case the drive was just not 'playing cricket'. Even using Powershell I encountered errors with the drive itself, so ultimately I abandoned this quest and decided on a fresh install and endure all the time consuming disadvantages of loosing my weekend.

On a positive note, this meant I could simply install the drive and get going on a new OS install with no faffing around on imaging. I updated the bios to the latest version 2904 which I figured would be best for newer hardware and installed the drive in the neat M.2 socket; so far so good. Booted and into bios, there was the lovely drive displayed in Sata socket 5. I made all the necessary bios changes and went to the boot menu to select the new drive as the boot device. Here I ran into problems again. I simply could not select the new Sandisk device for booting. Several reboots later, searches on Asus site (the motherboard is a Z97-K) I was no closer to a solution and a few HOURS later I was still no closer. The drive showed up in bios, but could not be selected for booting even though any other device I connected was immediately available.

Sometimes you just have to accept failure, and this is what I did. I figured the firmware version simply didn't properly support the drive and I would have to go back to a standard SATA SSD or, in this case as I had none to hand, a standard hard drive. In preparation for this escapade, I had however created a Windows 10 media creation disk and just wanted to see how it presented (having only ever done Windows 10 installs through the upgrade process). I stuck it in and booted going through the phases to check differences between it and prior versions of Windows. You can imagine my surprise when I got to the "Where do you want to install Windows" section and there before me was the M.2 Sandisk appearing bold as brass like a kid with new shoes. I exited, rebooted the machine and went into the bios menu. There listed as and available boot device was the Sandisk M.2 drive.

I have no idea why this happened, nor why the install sequence finally made this available, but I won't look the proverbial 'gift horse' in the mouth, but simply accept it as yet another technical oddity. The install when smoothly after that with Windows 10 even showing as 'Activated'. After witnessing the speed of this SSD card I was truly impressed and decided to go a step further. I had a spare Adaptec raid card and 8 500gb disks in the loft so I installed them and created a raid5 array as his storage drive. The speed of the storage on his pc is now blistering, data transfers between them is pretty spectacular and I'm amazed how programs just open instantly. The RAID controller means it doesn't actually boot that quickly as it has to boot that and initialize all the drives, but once its running, boy is the PC quick. At any rate, I doubt he'll be moaning for an upgrade any time soon.

Why the post... why not, maybe it will help someone out there with a similar problem, maybe it's just something to write during an moment of idleness.
1 - 1 of 1 Posts
Not open for further replies.