Tech Support Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
Hi, I am trying to play Rift and Im getting really low FPS in certain areas and Im not sure what I need to upgrade though I know I need to upgrade something. My Dell XPS 420 is ~8 years old.

Motherboard - Dell 0TP406 Chipset - Intell X38
CPU - Intel Core 2 Quad Q6600 2.4 GHZ
Video Card - Nvidia 460 GTX
Power Supply - 750w
Ram - 4x 2gig DDR2
Windows 7 64bit

I just got the video card and another 4 gigs of ram (up from 4 total), it didnt do anything for the fps so Im assuming its a motherboard and processor issue? I have similar problems in other games where it will run smoothly but only on low settings and if there are not a lot of other players in the area. NPCs load really slow when there are a lot of other players in the area. I always have to raid on low settings or my fps drops to like 10-15. I have no idea on how to go about getting a new motherboard, if its going to fit correctly in my manufacturers tower, if its going to have the right mounting brackets etc. There are no overheating issues from what I see. My processor stays between 140-150F while Raiding and 100-120 while not.
 

·
Administrator, Team Manager, Gaming, Team Manager,
Joined
·
54,105 Posts
CPU speed is the biggest issue, overclocked to 3.0-3.2 the Q6600 can still run pretty well but that unfortunately isn't a possibility on a oem Dell board, upgrading is going to take a Case(the 420 uses a BTX not ATX board) motherboard(The Intel 775 socket is end of life with only the G41 chipset left on the market) CPU and Ram(all new boards are DDR3).
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
So I need to get a new case along with a new motherboard and processor? Which probably means new fans also. Will I still be able to keep the DDR2 Ram?
 

·
Registered
Joined
·
58 Posts
i have almost the same pc spec.

is there a realtek soundcard on that board?
i played rift too...first i had problems with aion with realtek.

if you have a realtek onboard soundcard,try quitting the progress.its called rthcpl.exe or something.

after quitting i had no more problems :)
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top