Tech Support banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Sony laptop PCG-GRX670
Pentium 4 processor
Radeon 7500 video card
Microsoft Windows XP

While trying to update the drivers for my uncooperative Radeon 7500 video card (Windows telling me no better driver found, ATI software telling me no driver found at all!), I attempted to manually load a driver that I thought was correct.

Apparently, it was not the correct driver because after Windows all-too-correct warning and the necessary restart, I am no longer getting any picture at all.

I get the Sony screen, the Windows loading screen, but after that just a black abyss of nothing. I have reason to believe Windows is operating normally (I am able to do basic things like restart & shut down by pressing the obvious keys - Windows, Up, Enter, Right, Enter etc etc). Still, there's no way I'd be able to go into the settings and roll back the driver without seeing anything.

I haven't been able to get Windows to go into safe mode (am i pressing the right key in startup?) and even if was able to do that, would I get picture?

Any ideas? Help is greatly appreciated. Thanks!
 

·
Registered
Joined
·
18,118 Posts
After the computer completes the POST (initial boot phase) start pressing the F8 key until it gives you a list of options. Choose Safe Mode and let it go from there.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
yeah, i was actually just able to get into safe mode, and the problem is fixed. thanks a bunch for you help!
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top