Tech Support Forum banner
Status
Not open for further replies.
1 - 20 of 23 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hi there,

The problem seems to be a heritage from previous Windows versions. And seems M$ did not bother to work this problem out in Vista, there are still lots of requests in the net. Almost no "universal" solution up to date.

Although, my case is somewhat unusual.

At some point I noticed that the language bar had disappeared from it's usual place in the system tray. Thought it got hidden because it was inactive (I alsways use keyboard assignments). But that was not it. The usual sequence (alt+shift) did not work anymore. In regional settings->keyboards everything was fine as it should've been. Changes had no effect.


After surfing the net for two days found a temporary solution to at least be able to switch between layouts. I had to assign ctr+1 and ctr+2 to inmlement a "fixed" switching between the languages. Extremely uncomfortable.

Now the most interesting part. When a request for elevation appears (grey transparent background), I can see the language bar floating on desktop, I can touch it, move it, change input language. But once the request is comleted (OK or Cancel), it's gone!!

Another "mystery": the old scheme (alt+shift) works in non-unicode programs, such as command prompt, FAR etc. But doesn't want to work in any GUI application.

Any suggestions? I know XP registry fixes but they seem to be of no use in Vista.



--

Yakor
 

· TSF Team Emeritus , Microsoft Visiting Expert
Joined
·
3,263 Posts
Hi Yakor

Quick-Fix:
Do you still have a Language icon in your System Tray? (If you switch between installed display/input language choices, the current choice should show in the System Tray: such as EN for English, JP for Japanese, etc.). Make sure that you haven't chosen to "Hide inactive icons" in your Vista Taskbar "Properties" - or the icon might not be shown. If you can see such an icon, you should be able to right-click that icon, and choose "Restore the Language Bar" from the resulting option dialog box.

Quick-Fix #2:
Since the Language bar is a system setting, and the problem is recent, you might be able to retrieve your former settings using Vista's System Restore utility --- using a restore point from just before the Language bar disappeared. You'd likely have to visit Windows Update to reinstall any Critical Patches that arrived since the time the restore point was originally created.
_______________

Should neither of those approaches work, try visiting the Region and Language Options in the Vista Control Panel.

Control Panel
Clock, Language, and Region
Regional and Language Options

If you are using different languages with your input devices, you'd visit the "Keyboards and Languages" tab, and select "Change Keyboard" -- in the "Text Services and Input Languages" window, the middle tab is "Language Bar" -- I believe the option to show or hide the bar is available there. If you are only using different languages for display, you can go straight to the "Change Display Language" option from the Regional and Language Options (and try the "Language Bar" tab there).
______________

Best of luck
. . . Gary

P.S. If changes are not taking effect, try the changes in Safe Mode, and of course be logged in with Administrative rights.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for reply, OldGrayGary,

Of course I tried all of these. As I said, the language bar is not visible on desktop. It only appears at rights elevation request and hoes away after you do an action.
Any chages in "language bar" section have no effect.
The same goes for safe mode etc.

I'm probaby lloking for some registry solution, somewhere in HKEY_CLASSES_ROOT\CLSID\{540D8A8B-1C3F-4E32-8132-530F6A502090}

Restore is not possible, becuase I use dual boot (rarely, but from time to time) and as you know XP erases all Vista's restore points.

Thanks,

--
Yakor

Hi Yakor

Quick-Fix:
Do you still have a Language icon in your System Tray? (If you switch between installed display/input language choices, the current choice should show in the System Tray: such as EN for English, JP for Japanese, etc.). Make sure that you haven't chosen to "Hide inactive icons" in your Vista Taskbar "Properties" - or the icon might not be shown. If you can see such an icon, you should be able to right-click that icon, and choose "Restore the Language Bar" from the resulting option dialog box.

Quick-Fix #2:
Since the Language bar is a system setting, and the problem is recent, you might be able to retrieve your former settings using Vista's System Restore utility --- using a restore point from just before the Language bar disappeared. You'd likely have to visit Windows Update to reinstall any Critical Patches that arrived since the time the restore point was originally created.
_______________

Should neither of those approaches work, try visiting the Region and Language Options in the Vista Control Panel.

Control Panel
Clock, Language, and Region
Regional and Language Options

If you are using different languages with your input devices, you'd visit the "Keyboards and Languages" tab, and select "Change Keyboard" -- in the "Text Services and Input Languages" window, the middle tab is "Language Bar" -- I believe the option to show or hide the bar is available there. If you are only using different languages for display, you can go straight to the "Change Display Language" option from the Regional and Language Options (and try the "Language Bar" tab there).
______________

Best of luck
. . . Gary

P.S. If changes are not taking effect, try the changes in Safe Mode, and of course be logged in with Administrative rights.
 

· TSF Team Emeritus , Microsoft Visiting Expert
Joined
·
3,263 Posts
Hi again

It's beginning to sound like a job for SP1.

Curious, though = when you view your language settings in the Control Panel, do you still see the "Microsoft IME" item as installed alongside your language?

Have you tried uninstalling and then reinstalling the languages entirely?

Best of luck
. . . Gary

P.S. ... I'm hoping they'll put an item fixing the System Restore problem with dual-boots into SP1 as well, as it's a nuisance (I have a few multi-boot systems that share that same problem).
 

· Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Hi Gary,

Thanks for a hint, indeed it might have been SP1.


Curious, though = when you view your language settings in the Control Panel, do you still see the "Microsoft IME" item as installed alongside your language?
Everything is in it's place. Just the changes have no effect (except if you assign ctr+1, ctr+2 to the layouts/languages, but this doesn't restore visual presence of the language bar).

Have you tried uninstalling and then reinstalling the languages entirely?
Of course I did (if you mean keyboard section. if you mean MUIs, I have only English installed). No effect.

P.S. ... I'm hoping they'll put an item fixing the System Restore problem with dual-boots into SP1 as well, as it's a nuisance (I have a few multi-boot systems that share that same problem)
I doubt this can be fixed. It's the problem of XP, not Vista. This is even described in Vista Help, when you are in Restore Center.
It's simply that XP treats VSC's as invalid and erases them.

The only cure is (1) in XP to switch off monitoring on the disks where Vista's VSC's are stored given that (2) it is not the system disk [which is usually the case in majority of dual-boots]
 

· TSF Team Emeritus , Microsoft Visiting Expert
Joined
·
3,263 Posts
Hi again


You know, for as long as it took Microsoft to bring Vista to market (and even then, they had to leave out the planned new file system, and some of the other expected advances) --- Vista sure has a lot of rough edges to work on.

If you are feeling bored and curious some weekend --- I wonder what would happen if you actually added one of your extra keyboard languages as a display language also? ---> If the Language Bar reappeared then -- only to disappear again = that's one certain bug for Microsoft to work on.

At least they keep us on our toes :)
. . . Gary
 

· Registered
Joined
·
1 Posts
I am wondering if a solution to this has been found.

I am experiencing the exact same problem, with one possibly small difference. I have multiple users on the machine, my account is an administrator account, my son's is a standard user.
The other day I noticed that he had the language bar and was able to use it without any issues.

On my account, the bar is not visible and I cannot find a way to make it visible. It does appear when the system is asking for permission to continue. the language bar appears and seems to just be hanging around the screen somewhere, I can move it around but I cannot move it down into the task bar area. I cannot minimize it but I can select the menu items and change the settings.

Any new info would be apreciated as by some combination of keys, the language is sometimes switched and it is very difficult not knowing the combination, to get it back to normal...
 

· TSF Team Emeritus , Microsoft Visiting Expert
Joined
·
3,263 Posts
Hi lucho1970


. . . and Welcome to the Tech Support Forums!


Just to let you know, it is best and most gracious to our fellow members if we open our own threads when we ask for assistance. Many members receive email notifications for posts in their threads, and we don't want to flood the InBoxes with other members repairs. Thanks!

The best way to refer to a problem that you've noticed in other threads is to include a link to them in your thread (you can simple copy-and-paste it from the "address bar" in your Internet browser into the text of your post).

In the meantime, as regards your hidden Language Bar - look at Microsoft's details on it's operation & see if you haven't overlooked anything --- http://windowshelp.microsoft.com/Windows/en-US/Help/cc452fac-0858-4baf-bc01-005ef3c901751033.mspx

Of course, make sure that among your efforts to unhide the Language Bar, you've tried the standard method:

1. Click Start, and then click Control Panel.
2. Click Date, Time, Language, and Regional Options.
3. Click Regional and Language Options.
4. Click the Languages tab, and then click Details.
5. On the Settings tab, click Language Bar.
6. Click to select the Show the Language bar on the desktop check box, and then click OK.
7. Click OK to close the Text Services and Input Languages dialog box.

Best of luck
. . . Gary
 

· Registered
Joined
·
1 Posts
Re: Language bar cannot be restored. A fix.

This problem seems to be related to a bug in the task scheduler. Here's how I fixed it in my system:

Start task scheduler (Administrative tools) and select View -> Show hidden tasks.
Go to Task Scheduler Library/Microsoft/Windows/TextServicesFramework, where you should find a task named MsCtfMonitor. This task should run at user logon, so check the history tab looking for any errors. If you run this task manually you'll probably get the language bar back until you log off.
If everything seems ok but still no language bar after a reboot, then start regedit and go to HKLM/Software/Microsoft/Windows NT/CurrentVersion/Schedule/TaskCache/Logon. Under this key is a set of GUIDs that should correspond to existing tasks under the key HKLM/Software/Microsoft/Windows NT/CurrentVersion/Schedule/TaskCache/Tasks. On my system there were a few keys that did not have corresponding values under tasks. Backup the key, remove any bad entries, then reboot.

My guess is that the scheduler finds a bad task key at logon and stops without running any remaining tasks.

I hope this helps...
 

· Registered
Joined
·
1 Posts
I had the same problem with the language bar and re-activating the "task scheduler" service fixed the problem.

I had disabled the service with a start-up optimizer program. used that same program to re-activate it was all fixed up after a quick restart.

Thanks BlackDog!
 

· Registered
Joined
·
2 Posts
Hello!

I also tried what Black dog recommended too. At least up to the point of running MsCtfMonitor. It worked!
But when I restarted the computer the language disappeared once more.
I think am not that tech literate to know how to do what you mention about regedit. I don't know how to recognize the bad entries or anything regarding working on this section of the computer. Any help would be most appreciated!

Thanks!
 

· TSF Team Emeritus , Microsoft Visiting Expert
Joined
·
3,263 Posts
Hi all


flips08 --- it does pay to be careful when editing the Registry - but the repair that Black Dog has ingeniously crafted is fairly straightforward, and should be possible to do safely with a healthy dose of caution along the way.

To make a quick backup of the Windows XP Registry before trying your edit, simply go to XP's "System Restore" utility & create a "restore point". Easy! (and all the details are in "Help & Support" on your XP Start Menu).

If you'd like to read a little about how advanced users edit the Registry manually, Microsoft has an article for that --- http://support.microsoft.com/kb/256986/ --- but remember, System Restore is the easy way to back up beforehand, and for restoring if things go a little crazy.

As a quick tip .... you navigate in the Registry Editor ("regedit") very similarly to how you get around in Windows Explorer: it's a "tree" view. When you see an abbreviation in Registry instructions that mention "HKLM" as the starting four letters of a location in the Registry, that abbreviation refers to what you see as "HKEY_LOCAL_MACHINE" [articles about the Registry can be confusing for silly reasons, such as the naming nonsense that Microsoft used ... they rather mixed their metaphors, using both "handles" and "keys" as a metaphor for how things were organized, yet also referring to various parts as "hives" .... I find it much clearer just to look at that straightforward "tree" view in the Registry Editor: it's pretty much self-explanatory].

Last note: when Black Dog mentioned 'bad' entries in the Registry key for Task Scheduler, he was referring to those entries that were "orphans" -- the tasks they refer to are no longer present or possible, and so they should be removed. Incomplete uninstalls are a common cause of this sort of thng.

Best of luck!
. . . Gary
 

· Registered
Joined
·
5 Posts
I am wondering if there is anyway I could just permanently fix this problem. The language bar disappears from time to time and it reappears only after I manually run it from the Scheduler.

I double checked the RegEdit for bad files but as it seems, there aren't any on my system.

Many thanks,

Yana

:1angel:
 

· Registered
Joined
·
5 Posts
P.S.

I found a guy who has the exact same problem and writes about it in a forum (http://www.neowin.net/forum/index.php?showtopic=625250). So, I wanted to include what he says. Citing Directly:

"Hi,

I noticed sometime after installing SP1 that my language bar no longer appears. After some research I think the problem has something to do with the Task Scheduler, so I open TS and get an error saying:

"Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))"

If I run the "MsCtfMonitor" task, the language bar comes back until I log off.

Also, I checked the event log and noticed that every time I log on, the Task Scheduler generates an error:

"Task Scheduler service failed to launch tasks triggered by computer startup. Additional Data: Error Value: 2147549183. User Action: restart task scheduler service."

Any ideas? I'm using Vista Home Premium 64-bit.
Thanks."

I hope there is someone who could help me because this problem is bothering me a lot.

Thank you once again.

Yana
 

· TSF Team Emeritus , Microsoft Visiting Expert
Joined
·
3,263 Posts
Hi Yana


Have you tried Black Dog's repair since installing SP1? It can't hurt to try it again ... especially: remember to "show hidden tasks" when trying to figure what entry might be causing the problem.

Certainly: also run malware/rootkit scans, as malware can cause trouble for the Scheduler if they try to hide a process in there.

I'll have a look over at MS later on to see if they've anything new on Task Scheduler errors. Are these the only errors that you're currently experiencing on the system?

Best of luck!
. . . Gary
 

· Registered
Joined
·
5 Posts
Hi Gary,

Well, I have tried Black Dog's repair several times and i) either I am not doing it correctly (there is not "show hidden tasks" option in the RegEdit) or ii) there aren't any wrong entries.

I haven't had any other problems besides this one. My laptop is brand new, I am running Vista Home Premium, and the only other bug I have noticed is that Firefox freezes each time I launch it immediately after log on (however, I read somewhere that there isn't 100% compability with Vista yet and that's what causes the problem).

I run full system scan every three days or so and I haven't noticed any malware since now.

The only thing that bothers me is that message that I get when I launch the Task Scheduler: "Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))". Also, the "Task Scheduler service failed to launch tasks triggered by computer startup. Additional Data: Error Value: 2147549183. User Action: restart task scheduler service." error that shows when I check the event log.

I have no idea what may have caused this as my computer has been performing more than great but I am sure that the disappearance of the language bar and this few issues are somehow connected. I just need help to figure out how to fix it.

Thanks a lot for the attention to this.

Cheers,

Yana
 

· TSF Team Emeritus , Microsoft Visiting Expert
Joined
·
3,263 Posts
Hi again

Take another look in on Task Scheduler itself .. the "show hidden tasks" option is in there (not in the Registry Editor).

I took a little look around tonight, and noticed that several other folks with that error message had changed their usernames or passwords recently, and I wonder if that can cause scheduled tasks that were previously allowed permission to run -- to no longer be granted such permission, and thereby causing Task Scheduler to have its fits.

If you happen to have changed something like that recently, and you find items in the Task Scheduler using the "show hidden tasks" option that seem likely to have caused the problem -- then: 1) if you no longer need the tasks, remove them, or 2) if you do need the tasks to run, try removing them, closing Task Scheduler, re-opening Task Scheduler & re-entering the tasks into the scheduler.

Best of luck
. . . Gary

For your FireFox troubles, version 3 is said to have better Vista support. Version 3 has just become available this past week.
 

· Registered
Joined
·
1 Posts
Re: Language bar cannot be restored. A fix.

This problem seems to be related to a bug in the task scheduler. Here's how I fixed it in my system:

Start task scheduler (Administrative tools) and select View -> Show hidden tasks.
Go to Task Scheduler Library/Microsoft/Windows/TextServicesFramework, where you should find a task named MsCtfMonitor. This task should run at user logon, so check the history tab looking for any errors. If you run this task manually you'll probably get the language bar back until you log off.
If everything seems ok but still no language bar after a reboot, then start regedit and go to HKLM/Software/Microsoft/Windows NT/CurrentVersion/Schedule/TaskCache/Logon. Under this key is a set of GUIDs that should correspond to existing tasks under the key HKLM/Software/Microsoft/Windows NT/CurrentVersion/Schedule/TaskCache/Tasks. On my system there were a few keys that did not have corresponding values under tasks. Backup the key, remove any bad entries, then reboot.

My guess is that the scheduler finds a bad task key at logon and stops without running any remaining tasks.

I hope this helps...
Thank you very much, Black Dog!
You've helped me!
I researched solution few days!...
Now lang bar is present in my system

I think, Black Dog's way is right and only it is right!
 
1 - 20 of 23 Posts
Status
Not open for further replies.
Top