Tech Support banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter · #1 ·
my colleague at work uses a Dell Inspiron 1501, 512mb ddr2-4300, AMD mobile turion 64 2.0ghz running windows xp sp2, which i just updated to sp3
We have just reinstalled windows xp, as it was full of rubbish and we wanted to improve the speed of it:laugh:
before i reinstalled, i noticed that on my computer properties, it said that the cpu was running at 797mhz, however at times it does go back up to 2.0ghz.
It still does this after the reinstall.
The main issue is that there is almost constant keyboard lag, each letter will take a few seconds delay before it is on the screen.
I have tried everything i know, has anyone else had this problem before??
Could it be anything to do with the cpu freq issue? or ram?
any help is greatly appreciated:grin:
 

·
Registered
Joined
·
301 Posts
If you've only got 512meg of ram for XP, then you only have HALF enough.:4-thatsba
Dell is famous for NOT installing enough ram for the installed OS.

That computer will run MUCH better with a full gigabyte and even better yet with TWO.

When the keyboard is lagging it means that the CPU is too busy to service the keyboard. The keyboard has a very low priority.

Without enough ram, your OS is living off of the hard drive. That's over a thousand times slower than the ram it should be using.

Then if you've loaded some heavy duty, resource hog, like Norton, all bets are off for getting any kind of performance out of that underpowered system.

You could also have services that you don't need and background programs that you don't need....running all the time and just sucking up system resources.

Get more Ram.

Shadow :cool:
 

·
Registered
Joined
·
2 Posts
Disable the ATI HotKey Poller service in Windows.

Go to Start->Control Panel->Administrative Tools->Services

You should see the ATI HotKey Poller Services listed. Right Click on it and select properties. Halfway down the screen you should see the "Startup type." Choose disabled from the drop-down list, click apply, close out all applications and reboot. This should resolve your issues.
 

·
Registered
Joined
·
1 Posts
Thank you very much, Marcolian! Your solution has solved the issue on my Dell Inspiron 1501 as well - it seems that this process is added on installing updated ATI drivers and can't be closed via the ATI Control Panel.

It only serves for being able to control the display settings via keyboard shortcuts (kinda totally useless anyway), so I suggest to everyone to disable it via Run/services.msc.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top