Tech Support banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello,

I have a dell Latitude laptop D810 with a 2.5" 60gig 7200 Hitachi Travelstar, IDE/ATA 100 hard drive.

I also have an external IDE/ATA hard drive connected via usb 2.0.

I downloaded Bart's Stuff Test, and ran the quick test and here are the numbers i came up with:

(Avg's)

Internal:

Write- 2MB
Read- 1.7MB

External:

Write-20.1MB
Read- 24.5 MB

Can someone explain why my internal hard drive is running so slow? I know reaching theoretical speed is not going to happen, but good lord...

I have about 1.4 free gigs on the internal and 14ish on the external, could this be the problem?

Thanks!

Jason
 

·
Registered
Joined
·
23,001 Posts
Hi :wave:

See if DMA is enabled for the internal drive (if not it will be slow).

Have a look in Device manager:
Double-click IDE ATA/ATAPI Controllers >
Right-click the channel your HDD is connected to > Properties > Advanced Settings > Enable DMA.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
It is.

I am still wondering if the amount of free space has anything to do with it?

I ordered a new external drive, so i will let you know when i get some information moved over.
 

·
Premium Member
Joined
·
78,003 Posts
you need to have at least 10% free space on a hard drive just to defrag,you will end up losing access to the drive alltogether
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
I have moved quite a bit off the drive and defragged. I now have 20gigs free.

The drive is still running really slow.

Under the device manager there are three entries:

Intel 82801FBM Ultra ATA Storage Controllers- 2653
Primary IDE Channel
Secondary IDE Channel

Under primary channel the option is set to DMA if available, but it is running in PIO mode.

Under Secondary IDE, the option is set for DMA and it is running ULTRA DMA MODE 2.

This is a laptop with just one hard drive in the bay. Why is it giving me two channels, with the primary in PIO?

The drive itself supports ULTRA DMA mode 5(ULTRA/ATA 100).

Something is wrong for it to be running at 2.1 MB/sec transfer rate.
 

·
Premium Member
Joined
·
78,003 Posts
spotila
Registered User

Join Date: Oct 2004
Posts: 49
OS: XP

Manually Setting DMA
go to the reg. key :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001 or 0002 (depending on beeing primary[0001] or secondary[0002] ide channel)

there you modify the DWORD value of :
if the drive is on master: "MasterDeviceTimingModeAllowed" or
if the drive is on slave: "SlaveDeviceTimingModeAllowed"
to ffffffff

then go back to your device manager set your drive in IDE channel properties first back to pio and then, after confirming, again to dma ...that should do the trick[/b]
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top