Tech Support Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I'm having a long-standing issue with the wireless internet signal on my computer connecting and disconnecting seemingly at random. This appears to occur at multiple locations using different routers (although I'm unsure as to the brand of one such router, and so the other router's information is supplied).

My computer is an HP desktop running Windows Vista. I'm aware that Vista may be the issue, but it cannot be fixed (my computer won't dual-boot XP because it's "incompatable").

The wireless router is a Linksys Wireless-6 24 GHZ Router, and the wireless card is a Linksys Wireless-G PC1 Adapter. They are fully updated.

The computer has a good signal when it's connected, and it DOES connect. However, after a while (a random amount of time), the connection will drop off for no apparent reason (also for a random amount of time). :4-dontkno

The wired internet works, but we have to run it through half the house, so we'd like to be rid of this problem if possible.

If you have any more questions, please ask, and I'll try my best to answer them. Thank you for helping!
 

· Global Moderator
Electronic Design
Joined
·
52,687 Posts
Why can't you supply the make/model of the other router? Obviously, that might have a bearing here.

Have you tried changing channels on the routers?




Changes that may help to increase the compatibility of Vista with older networking devices:



Disable the IP Helper service:

1. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter
2. Scroll down to the IP Helper service, right click on it and select Properties
3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
4. Then click on "Stop" to stop the service from running in the current session
5. Click OK to exit the dialog



Disable IPv6:

1. Hold the Windows key and type R, enter "ncpa.cpl" (without the quotes) and press Enter
2. Right click on each network connection and select "Properties"
3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
4. Click OK to exit the dialog

NOTE: You should do this for each network connection.



Disable the DHCP Broadcast Flag:

Link: http://support.microsoft.com/default.aspx/kb/928233
  1. Hold the Windows key and type R, enter regedit and press Enter.
  2. Locate and then click the following registry subkey:
  3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
  4. In this registry path, click the (GUID) subkey to be updated.
  5. If the key DhcpConnForceBroadcastFlag does not exist, use the Edit menu, point to New, and then click DWORD (32-bit) Value. In the New Value #1 box, type DhcpConnForceBroadcastFlag, and then press ENTER. If the key exists, skip this step.
  6. Right-click DhcpConnForceBroadcastFlag, and then click Modify.
  7. In the Value data box, type 0, and then click OK.
  8. Close Registry Editor.
NOTE: You should do this for each and every GUID subkey.
NOTE2: (GUID) is a mnemonic for the individual subkeys, the actual text "GUID" does not appaer.




The only program I'm aware of that currently relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top