Tech Support Forum banner

Intel(R) PRO/Wireless 2200BG

2368 Views 25 Replies 3 Participants Last post by  makinu1der2
Hi, about 3 months ago, on my Toshiba Satellite 32-Bit Home Basic Windows Vista laptop, when i go to Connect To it shows absolutely no networks that i could possibly connect too. My WiFi switch is set to ON and there is a light on.

This is what my network section has in it:

Everything is fine except for: Intel(R) PRO/Wireless 2200BG

I have tried to update it, and stuff, but still no effect. I am able to connect to the internet with a cable attached, but i would really like to have my wireless back. Can someone please help me?
See less See more
Not open for further replies.
1 - 20 of 26 Posts
How do i check what Model i have?
It may be on a sticker on the bottom.

Most models will have it marked on the laptop.
what exactly am i looking for? i got alot of stickerso n the bottom,

I got like Model Number, Seriel Number. and stuff like that.
Model NO: PSLB8U-0D8038
So does anyone know why this is happening? :(
That number doesn't pull up anything. (Example: satellite L305-S5689)

Go here and choose your system model. You should then be able to install the wireless driver.
Ooooo i see

Satellite L305-S5915
Have you checked your list of devices in the Device Manager in Control Panel for any yellow or red flags. You might right-click on the wireless device and examine the properties for anything that looks out of place.
Bmegenity, I have tried several times, but there is simply no solution to my problem. :(
Have you uninstalled and reinstalled the wireless device?
Idk what to install or reinstall, or where to get it from. Or how to do it. :( im stupid
About too, Thanks alot for the help, if i need further instructions ill ask. :)
Punchroll: your question and follow-thru are sure signs that you're not stupid. None of us know everything but maybe we can help you figure out how to get out of your problem. I'm going to back out now and let makinu1der2 continue. It looks like he's giving you some good advice. Good luck.
I installed the driver, but still when i go to Connect To: I get no Wireless Connections.

Im pretty sure that my network card is fine because if i get connected with a wire, that should mean my network card is right.. Any other suggestions makinu1?
Do you still have the exclamation in Device Manager? If so right-click the device and uninstall it and restart Windows.

Yes you NIC port is fine.

But in the previous Device Manager screenshot that you posted show a problem

with the Intel wireless driver. It shows you also have the Atheros wireless driver loaded.

I believe this is causing your issue of not being able to connect wirelessly.
1 - 20 of 26 Posts
Not open for further replies.