Tech Support Forum banner

Installshield Error

3241 Views 9 Replies 4 Participants Last post by  txgirl4uh
I am having a major problem trying to install some s/w (Sansa MediaConverter) on my P4, Win XP SP2 PC.

Just as the s/w begins to install I get a fatal error - (something like) "Unable to create a file that already exists ... C:\Progam Files\Common Files\Installshield\engine\6\Intel 32\iuser.dll"

Since I was able to install the s/w on a friend's similar PC I think the problem is a compatability or bug with the Installshield appln on my machine.

I followed some suggestions (from the Installshield support site) and cleaned up my temp file, deleted the 'Engine 6' folder and reinstalled the Installshield 'ikernal.exe' but this hasn't helped.

Surprisingly when I tried to reinstall the 'ikernal' it also runs into exactly the same error! - so there is some issue with how the Installshield (Engine 6) is working on my PC.

Will be very appreciative for any ideas and advice on how to resolve this.

Many thanks.

P.S. I have had no other problems installing and running programs on this PC!
Not open for further replies.
1 - 10 of 10 Posts
Is there anything on the website about re-installing Installsheild?

Try using a Registry Cleaner, you may have to pay though.

A good one is Registry Mechanic. Google it.
Thanks for the ideas Nitrus.

I guess redoing the ikernal is kind of like doing a partial reinstall of Installshield but I'll check further about doing a more extensive reinstall.

I have Reg Mechanic so I'll clean up the registry and let you know.

Happy New Year.
Ya, it sounds like a Registry error. Give it a go and post back.

Reboot after you have cleaned your registry, then clean it again and install the software.

Some advice: don't delete anything with "reg cleaners" unless you know what it is.

Scan the d/loaded file and your computer for virus, malware.
I am confident the appln s/w and my PC are clean from Viruses etc.

I scanned (a couple of time, including rebooting) my registry and tried reinsatlling the SMC but wound up with the same error.

There seems to be a fundamental problem with Installshield since I get the error even when I try re-installing the ikernal.exe Installshield s/w.

Hopeful for more suggestions...
Hi Gemo,

After C:\Progam Files\Common Files\Installshield\engine\6\Intel 32\iuser.dll" do you get The parameter is incorrect ?

Whats the directory location you're trying to install this software from?

I've seen this occur if the dir path is unusually long.
Thanks for the comments Kalim.

I don't think/remember seeing any reference to "Parameter is incorrect'.

I have tried installing the the s/w from both the supplied CD and from an exe file (downloaded from the Sandisk site) on my harddrive. I don't think the path names would be any longer than usual.

The install path is basically c:\Program Files\Sandisk\Sansa Media Converter\.

Have asked Sandisk tech support for help but so far none of their basic suggestions have helped.

Welcome any further ideas...
Hi Gemo,

What I meant by the install directory is where the .exe you are running is located- usually on the desktop. Anyway, thats bypassed by the fact that you ran a CD which is in the root directory: drive letter:\

Have a read and follow this: Clean the Temp

Try the installation again. If it doesn't work, then have a try of this: Install ikernal

Hopefully one of those will work.
I need help with installing programs too!

I have read through all the threads I can and I have not been able to find any help. I am having problems installing programs on my computer. They will all say that it is complete, but nothing new will open. I tried downloading a new version on Installshield, and when it c ompleted, I clicked on the icon and see the page for a split second, then it goes away again. Does anyone have any ideas?

1 - 10 of 10 Posts
Not open for further replies.