Tech Support Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey guys,

I am absoultely stumped with this problem. I cannot get any USB ports to work on my computer. Whenever I try to install drivers in device manager it stops halfway through and I get the message "the device is not valid" and it then stops. I have tried taking out the power cable and then restarting the machine again but that didn't work. I have also edited the registry as a lot of posts online suggest that this problem is to do with the issues with permissions in xp and you can go into the registry and enable devices that way. Still no luck though. I have also tried to reset the registry to default settings but that also does not work. Anyone got any idea how to fix this problem?:sigh:
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hey TSF thanks for your prompt reply :rolleyes:

I am currently on service pack three of XP Professional

unfortunately, I'm having trouble getting hold of the disks
so haven't been able to do a reinstall
 

·
Registered
Joined
·
1,553 Posts
Hi, no I just wanted to see if you had the disks as I wanted to see if you could grab the Driver.cab file from the XP CD and replace it with the one you currently have in C:\Windows\Driver cache\i386 as that is probably the cause.
A re-install might not be necessary. Can you borrow a Windows CD from a friend, or do you have another computer in your house with the same version of XP running on it?
 

·
Registered
Joined
·
1,553 Posts
Hi, firstly if you do attempt it, make sure you first backup the old Driver.cab (just rename it OLDDriver.cab and then place the Driver.cab file that you can get off of the Windows XP CD in the same folder as the 'newly' renamed OLDDriver.cab.
To get it off the CD, put the XP CD in to the computers CD/DVD tray and when the Welcome screen appears, click 'Perform additional' tasks and click 'Browse CD'. Then double click the I386 folder, locate the Driver.cab file and copy it (CTRL+C or go to 'Edit' at the top of the screen and select 'Copy') then on your computer go to C:\Windows\i386 and paste it into that folder where the old one was.
Once that is complete, try to install the drivers again.
If you don't have the XP CD, you could copy (not take) one from another computer running the same version of XP. But remember to ask them first.

If you get stuck, follow this guide.

I would also like to know first though (and I should have asked this first) have you just done a new install of XP recently? If you have, did you install the chipset drivers for your motherboard first?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Hey there, thanks again for the extra info.

I tried the above fix without success. Still get the same message when I try to reinstall the drivers on any of the USB ports, i.e. the files always start transfering and then stop halfway through with a message 'the data is invalid.'

I have not done a reinstall yet. These are all the things I have tried so far....

The machine is 2 years old and was working OK until the USB ports stopped working. They would not recognise data storage sticks or my MP3 player cable and would instead try to install them and then stop halfway through with 'the data is invalid message'. Strangely my wireless internet usb stick did still work. In order to rectify this I unistalling all the drivers on the USB ports and then turning off the machine in the hope it would automatically reinstall them again. It did not install the drivers on any ports so now I could not even use my wireless internet usb stick.

I then tried reinstalling the drivers using the driver installation cd that came with the motherboard but that didn't work.

I then bought a PCI card with some new USB ports but when i plugged that into the machine the computer did not recognise the new ports

I then edited the registry by trying to enable each single usb port so that it had full control but again, same problem again.

I have also tried pulling out the power cable and then restarting after that but still nothing :sigh:
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top