Tech Support Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
HP D7160 Photosmart USB-printer+WinXP: "New hardware found"-wizard keeps popping up.

I will try and explain everything I did and tried, so please bear with me...

First of course I followed the instructions in the manual that comes with the printer: setting up the printer was completed succesfully, and then comes the task of installing the software.
So as the manual states, I put the CD-ROM in the CD-ROM drive and the setup starts. I choose the options I want (I also tried it with all the standard options and all the combinations I could think of, before anybody asks) and installation starts.
At some point, the setup tells me to connect the USB-cable, which I then do. Then you get something like a test-screen, where an animation starts like it's checking the USB-connection (the screen also says: hardware recognized).
But since I use Windows XP, the "New hardware found"-wizard also pops up... The manual tells nothing about this, so I was a little confused the first time. But I figured I had to use the setup from the HP CD-ROM and not the Windows setup, so I clicked Cancel. After a while, the HP USB connection test fails, but it lets me continue installing all the additional software.

At that point, the printer doesn't print: it doesn't show up in the Printers/fax window, and not in the print window when I try to print from Notepad (or any other program).

When I try to run the setup program again, I get to the same USB connection test, but this time, on the "New hardware found"-wizard that pops up, I choose Continue and let it do what it does. When I do this (although it's not mentioned in the manual) I get green light from the USB connection test, the printer gets installed and appears in the Printer/fax screen, the Device manager, and all the programs I want to print from.

The thing is, it also installs several other "hardwares" (?). Like a USB mass storage device, an external disk and a generic volume (I'm not on an English system, so I don't know if the translation is correct, sorry...) And in the Device manager, there are several other new entries that I don't understand what they have to do with the printer. But there are no question/exclamation marks or other problems, and the printer works, so it could have been okay.

But now, whenever I turn ON my computer even when the printer is powered off, the "New hardware found" wizard starts again and tries to install the generic volume it finds again, and the external disk and USB mass storage device. The same thing happens when I turn OFF my printer (not when I turn it ON, go figure...).
No matter if I let these things install (again) or I choose cancel, the same things happens again and again even after removing and installing all the software and drivers, either via the CD-ROM or the newest driver download from HP.

Also, in the lower right corner of the screen (near the clock) I see a green "safely remove USB device"-arrow that I usually only get when I connect a USB-stick or an external hard-drive. I think Windows thinks that's what my printer is, but obviously, it's not.

Does anybody know how to stop the "New hardware found"-wizard from starting every time and Windows recognizing my printer as a storage device? I know you can disable it completely, but I'm not looking for a work around, but a solution.

I really hope somebody can help me, thank you very much!
 

·
Registered
Joined
·
1 Posts
Re: HP D7160 Photosmart USB-printer+WinXP: "New hardware found"-wizard keeps popping

I have a very similiar problem. My HP printer all in one was working fine for more then 5 months and stopped suddenly. I have reinstalled, uninstalled, etc.. numerous times. The installation using the CD ROM does detects the printer but then cancels as it can not connect. I then receive a windows message that there is a problem with my hardware Office Jet 6400 -specified port unknown. It then proceeds to install the printer but it also installs a Mass Storage device. However, I can no longer print. I have tried removing all USB's from device manager but it always comes back after reboot. I have safely removed all devices and started over. My flash drive works fine as well as my camera in the same or other port. Any help would be appreciated.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top