One of the really annoying things about automatic updates in Windows is having your computer automatically restart when it has finished. I know that updates are very important, but being able to disable the auto restart is for me one of the first things I do. However, it is important to realise that as many of the updates are important for the security and general well being of your computer, so you should reboot occasionally to let the updates take effect. In Window 7 you are at least given the option to postpone a restart from 10mins to 4hrs, but in XP you get 10mins. We will be using gpedit.msc to make these changes.

Please note that you do not have gpedit in the Home versions of either Windows XP or Windows 7

First lets start with Windows 7. Press you Windows key + R (or press Start and then typeRunand you will see it at the top. Click on it to access the window. In the window type gpedit.msc and click OK to get to the gpedit screen



Once you have typed gpedit.msc and pressed OK you will see the following screen



Now navigate to Local Computer Policy>Administrative templates>Windows Components>Windows Update and select No auto-restart with logged on users for scheduled automatic updates installations. Double click on this and you will see the next screen



By default it will be on Not Configured. Simply change this to Enabled and press OK. Then close the gpedit window and you are finished.

Now lets look at how to do this in XP

Press you Windows key + R (or press Start and then click Run. In the window type gpedit.msc and click OK



Now type gpedit.msc and press OK, to open the gpedit window



Now navigate to Local Computer Policy>Administrative templates>Windows Components>Windows Update and select‘No auto-restart with logged on users for scheduled automatic updates installations. Double click on this and you will see the next screen



By default it will be onNot Configured. Simply change this to Enabled and press OK. Then close the gpedit window and you are finished.

That’s it, you’re done!

Now for those who have Home editions, there is a workaround.

For Home users of XP go Start>Control Panel(switch to classic View) and double click on Automatic Updates which will show you the following options



Select Notify me but don’t automatically download or install them. Select Apply and then OK and you are done.

Now Windows 7 Home users:

Go Start >Control Panel (view by ‘small icons’) and double click on Windows Update on the left of the window select Change settings and you will see the following window



In the Important Updates bit at the top, change the option to Check for updates but let me choose whether to download and install them. Press OK and you are done.

Just remember that you should download these and install them properly with a reboot sometimes.

I hope this has helped some of you out.

© 2011 techsupportforum.com