Tech Support Forum banner

Hosted VPN, IP Forwarding, Routing and Bridging

3077 Views 2 Replies 2 Participants Last post by  Lewi-G
I have got a PC at work (Windows XP Pro SP3) that is on two networks with the IPs, subnet (internet enabled) and, subnet (no internet). On the 10.0.0.X network there is a gateway with the IP allowing access to another network; 192.168.60.X, subnet (no internet). I have added the route on my work PC to access the 192.168.60.X network via this gateway and I can access all PCs on all three networks from this PC.

Now, I am using LogMeIn Hamachi so that I can access the networks at work from home. The PC at work is the 'gateway' PC on the Hamachi network. When installing Hamachi it created a new network connection and bridged this connection with my network adapter to allow access to the 10.20.30.X network from an external PC when connected using the Hamachi VPN connection. I have manually configured my Hamachi connection on my PC at home to the IP, subnet, with the default gateway set to I can ping all computers on the 10.20.30.X network from my PC at home.

I then added a route on my PC at home for 10.0.0.X to go via (the 'gateway' on the Hamachi network). I also enabled IP forwarding on the 'gateway' PC (my PC at work). I can not ping any PC on the 10.0.0.X network from my PC at home apart from (the other NIC in the Hamachi gateway PC) and (another PC on the 10.20.30.X network that is also on the 10.0.0.X network).

Now, with IP forwarding enabled on the Hamachi gateway PC I would assume after adding the route on my PC at home for 10.0.0.X traffic to go via that I would be able to ping all PCs on the 10.0.0.X network...

I also tried adding a route on my home PC to send all traffic for the 192.168.60.X network via which has a route via to the 192.168.60.X network, but this also did not work.
I then tried adding the network adapter into the network bridge that the Hamachi connection made, also keeping both IPs ( and on this network bridge by adding them into the 'IP Settings' in the 'Advanced TCI/IP Settings'. I also added the gateway for good measure. I still cannot ping any PC on the 10.0.0.X or 192.168.60.X networks from my PC at home.

I have also added the route to the 10.20.30.X network on a PC on the 10.0.0.X network to go via and tried pinging a PC on the 10.20.30.X network but this also has not worked. Also setting the default gateway on a PC on the 10.0.0.X network to does not allow this...

Surely bridging the networks and on my work PC would allow another PC on the 10.0.0.X network to access the 10.20.30.X network after adding the route or setting as the default gateway?

Have I missed something?

Does anyone know a way of doing this using what I currently have?

Thanks in advance...
See less See more
Not open for further replies.
1 - 2 of 3 Posts
Yes, I'm one of the admins of the network.
The 10.0.0.X network is home to a couple of video servers and a few client PCs that control various services on the servers. The 10.20.30.X network is a company wide network with internet access. The 192.168.60.X network is home to a wider video server network and has various PCs for many different uses. All these networks have a subnet set to
The 10.0.0.X network is a bit of a legacy network that is not likely to be changed anytime soon. The main thing that I want to be able to do is access the 192.168.60.X network using the Hamachi VPN which connects to the 10.20.30.X network via the PC with IP which has the route to this network via a gateway on the 10.0.0.X network (IP
1 - 2 of 3 Posts
Not open for further replies.