Tech Support Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

· Registered
Joined
·
3 Posts
Hi. I'm new to this forum. Anyhow, I just recently transitioned to windows 7 Professional from Vista business and did a clean install deleting all my files. I'm currently using a Sony Vaio laptop, VGN-SZ79GN-c, and went to their website support for the drivers of my laptop. However I am having trouble with the USB port. I have problems ejecting external USB storage because even after clicking on eject the drives are still visible in the "My Computer" window.

I also have an external HD 500gb (Buffalo brand) that uses usb to plug in (no firewire). Like it did in the past it would register as a hard drive in the "My Computer" window. However I can't seem to find the option to eject the drive. where it would normally be (either through right click or ejecting from the the options on the window).

I'd appreciate some help. Thanks in advanced.

Is it normal for windows 7 to have drives visible even after they have been ejected? Either that or i can no longer eject any of my external removable drives.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I seem to have got it working. I just changed some settings on how windows recognizes the devices.

Under:
Properties -> hardware -> properties -> Policies

I just set it to "Better Performance". Otherwise it'd be set on quick removal by default which says that you can remove the device without using the safely remove option.

I wonder if this is a new windows 7 feature or one I just have not come across before.

BTW am I allowed to post problems i have with video playback on my laptop?
 

· Moderator; Hardware
Joined
·
20,064 Posts
You can post any problems that you are having. Just be sure to post them in the correct section and please don't double post for the same issue.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top