Tech Support Forum banner

Help: PC freezes at: "Inspecting hardware"

1015 Views 0 Replies 1 Participant Last post by  MaryGh
Hello experts - I hope you can help me with this problem.

I have a PC with Windows XP SP2. It had two HDDs, one (IDE) with partitions C: (boot) and D:, and another (IDE) 200GB disk, E:.

Recently, the second disk caused the system to issue filesystem error messages on boot. I decided to image it to another location on the home LAN, and then to copy the image to a new disk.
So I have used "Live Ubuntu" "ddrescue" to salvage the disk image (with only about several k of error sectors) to another file on an SMB share.

I then got a new 500 GB SATA HDD, used a "Promise 4302" IDE-to-SATA PCI controller to interface to it, loaded the "Live Ubuntu" and used "ddrescue" to copy the old disk image to the new HDD. (The Ubuntu kernel 2.6 recognized the SATA disk and its "Promise" controller with no problems). So far, all according to instructions.

Now, according to instructions, the next step is to boot the XP system and let it do CHKDISK /F on the new disk.

The problem is: the computer freezes (hangs) in the initial step of the boot.

I tried to do a "Repair install" using an XP install CD - again the PC freezes after the message: "Inspecting your hardware".

Using the same XP install CD, it tried going into the "XP Recovery console" (in order to do "CHKDISK /F") - again, the PC freezes after "inspecting your hardware".

Booting the same PC from an Ubunbtu Live CD, situation is much better. When Ubuntu boots, it says: "Incomplete multi-sector transfer, Input/output error", but then it continues normally.

lshw says:
Hardware: HP Pavilion A305W, Trigem Glendale motherboard, CPU: Intel Celeron 2.7 GHz
Memory: 2GB DIMM DDR
Storage: IDE Intel 82801 (ICH4)
Logical: /dev/sda
/dev/sda1 Volume 0: FAT32 5692 MiB, primary fat initialized
/dev/sda2 Volume 1: NTFS 31 GiB, primary ntfs bootable initialized, modified by chkdsk: true, state: dirty, upgrade on mount: true, resize log file: true, mounted on NT4: true
Logical: /dev/sdb
Promise SATA 300 TX4 disk controller, Disk: Size: 186 GiB, Capacity: 465 GiB, Capability: NTFS initialized, modified by chkdsk: true, state: dirty, upgrade on mount: true, resize log file: true, mounted on NT4: true
IDE CDROMs: 0 and 1

Running fdisk -l on /dev/sdb:
Disk /dev/sdb: 500 GB, 500105249280 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 1 60802 488392033 83 Linux
Warning: Partition 1 does not end on cylinder boundary.

I read somewhere that I should change the partition ID from 83 to 0 or 7 (NTFS). But using fdisk (or cfdisk) and changing the partition ID (=type) (and doing "w" - namely: save) - does not actually change the ID.

What to do?

Thanks in advance - MaryGh
See less See more
Not open for further replies.
1 - 1 of 1 Posts
1 - 1 of 1 Posts
Not open for further replies.