Tech Support banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Please i need help, cant figure this ine out.

I cant get the S-ATA to work, i have the following

IDE 1 Pri 80GB Sys Drive
IDE 1 Sec 125 GB work drive
IDE 2 Pri Pionner 106
IDE 2 Sec 125 GB work drive
IDE Raid Pri 125 GB work drive
IDE Raid Sec 125 GB work drive

SATA 1 80GB Work Drive

As all these drives are std IBM ATA133 drives the one linked to the SATA cable uses an IDE to SATA adaptor.

I presume that it's somthing that i havent set right in the bios, but i dont know what.


Hopeing someone can help???

Regards

Dominic Irving
 

·
Guru
Joined
·
1,315 Posts
What O/S are you trying to use this with?

I ask because there are some restrictions with O/S's other than Win2K and WinXP. And yes, when the restrictions are applicable, BIOS setting changes are needed: see section 2.8.3 of your mobo manual.

Can you tell me more about your ATA to SATA adapter?

-clintfan
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
The OS is Win XP Pro.

The adaptor is a small board that plugs into the HD'S IDE port and has a small power take off (to power the board I would think) and the a socket for the S-ATA cable, other than that there is'nt realy anything else to tell.

Dominic
 

·
Guru
Joined
·
1,315 Posts
XP Pro will support up to 6 drives off the Southbridge, so the 4-drive restrictions I mentioned don't apply.


Check your BIOS setup. From the Main screen, arrow-down to IDE Configuration and hit Enter. There you should have settings as shown in section 4.3.6 of your manual, i.e.:

Onboard IDE Operate Mode= Enhanced Mode
Enhanced Mode Support On= S-ATA
Configure S-ATA as RAID= No
IDE Detect Time Out (Sec)= 35

Also from the Main screen, assuming you've connected the SATA to the Southbridge SATA1 port, arrow-up to Third IDE Master and hit Enter (SATA2 would be Fourth IDE Master). On the screen that appears, make sure everything is set to "Auto" except the last field, which should be "Disabled", i.e.:

Type= Auto
LBA/Large Mode= Auto
Block (Multi-Sector Transfer) Mod= Auto
PIO Mode= Auto
DMA Mode= Auto
SMART Monitoring= Auto
32Bit Transfers= Disabled


I wasn't sure if that pair of 125GB drives on the Promise are already operating in a RAID mode or not. Does the SATA drive work if you attach it to a Promise SATA port (meaning, SATA_RAID1 or SATA_RAID2)?

If not already configured for RAID, then in your BIOS setup Advanced screen, Onboard Devices Configuration, you clearly already have Onboard Promise Controller= Enabled;
check that you also have Operating Mode= IDE.

You could try updating your BIOS to 1010 if you haven't already, to see if it makes any difference, though my mobo worked fine even with 1007; see Asus P4P800/P4C800 Series: How to Update BIOS for full details.


AFAIK there just aren't any other BIOS settings which affect SATA, and there are no jumpers for it. If all these settings are as shown, and you are sure your drive has power, but you can't get that drive to work in any of your 4 SATA ports, then I would say the IDE-to-SATA adapter you are using, either doesn't work, or won't work.

-clintfan
 

·
Registered
Joined
·
9 Posts
32-Bit Data Transfer

clintfan said:
hit Enter (SATA2 would be Fourth IDE Master). On the screen that appears, make sure everything is set to "Auto" except the last field, which should be "Disabled", i.e.:

Type= Auto
LBA/Large Mode= Auto
Block (Multi-Sector Transfer) Mod= Auto
PIO Mode= Auto
DMA Mode= Auto
SMART Monitoring= Auto
32Bit Transfers= Disabled
What's the story on the 32-Bit Data Transfer switch, btw? If it's this , doesn't it sound like it'd be supported in most new hardware? Do you find out if you can enable it by reading SATA controller or hard disk specs?

- Everett
 

·
Registered
Joined
·
376 Posts
Correct. The 32-bit transfer is the same as described in that link, and should be enabled for best performance. I have no problems running with it enabled.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top