Tech Support Forum banner
1 - 1 of 1 Posts

· Registered
1 Posts
Discussion Starter · #1 ·
I use both iPhone 11 Safari and iPad 14.7.1, I use Chrome primarily on this ipad and Safari as well. I’m having this annoying issue where I go to, a forum website, and I try to create an account. For some crazy reason, every other link works on there including the ability to sign in using Facebook, Google, Twitter, and Microsoft, but I want to create an account within this website so that I can have the ability to change my display name instead of using the username that is associated with my Google account, Facebook, etc. So I go to the register button, I enter in my details correctly and follow the password rules, and when I click on “create account” it just does nothing.. it’s the same with the button I try to click on to contact the website owners.

Does anyone else have this issue or is it just me? Why is this happening and how do I make this link clickable? I’ve tried various things like trying in different browsers (it doesn’t work on Safari, Chrome or Firefox) and I have tried following some instructions that are shown on the Google search results, like turning something off and on on content settings, etc. I don’t have this problem with any other website. I also tried holding the button down, it continues to do nothing. There’s a message that pops up on the signup page that doesn’t show up completely on the screen no matter what I do and I have tried copying and pasting the message into the Google search, which gives me the error message “This site key is not enabled for the invisible captcha.” I know nothing about what this means, but I even went through and followed the instructions to enable the key for Invisible Captcha and this seemed to not solve anything. Any help is appreciated.
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.