Tech Support Forum banner

Has my power supply died?

2062 Views 7 Replies 3 Participants Last post by  blueeon
Few days ago, I went to turn on my desktop (intel Q9300 @ 3.3ghz (OC'ed, of course), Nvidia 8800GT, 4 GB DDR2 ram, Biostar TP45 mobo). I was greeted with no video signal. First instinct was that it was the graphics card. Having an older 7600 GT, I decided I would see if that one worked and if so, then I'd just replace the card since I had been meaning to anyway. Well, the older card worked. Against my better judgment, though, I decided not to test the 8800 GT in the older computer that the 7600 GT was just in.

I ordered a Geforce 465 and it got here today. Went to install it, turned it, and no signal. So, I then decided to test the 8800 GT in the older computer and it worked.

Now, the afflicted computer turns on, the fans start up, and there are no beeps. I have tried resetting the BIOS, checking all my cables. and short of testing the older PSU in this computer, I don't know what else to do. The mobo seems fine since the 7600 GT worked in it, but I'm guessing the PSU is faulty. It's a CORSAIR CMPSU-750TX 750W and has served me well for the past 2 and half years. Now, it has 60 amps on the 12V rail, whereas the older one that I could test has only 19, is that sufficient enough to test to see if it is indeed the PSU, or should I take a chance and buy another?

Thanks for any help. It is greatly appreciated.
Not open for further replies.
1 - 8 of 8 Posts
I would have to doubt the Corsair PSU being the problem but it is a possibility. How old is it?
I assume you have checked the monitor & cable?
The BioStar Mobo, being low quality, would also be a suspect.
Remove all the RAM and see if the Mobo beeps.
I would suggest a bench test.

Remove everything from the case.
Set the motherboard on a non conductive surface. The motherboard box is perfect for this. DO NOT PLACE THE MOTHERBOARD ON THE STATIC BAG! It can actually conduct electricity!
Install the CPU and heat sink.
Install 1 stick of RAM.
Install the video card and attach the power supply connection(s) to the card if your card needs it.
Connect the monitor to the video card.
Connect the power supply to the motherboard with both the 24pin main ATX Power connection and the separate 4 or 8 pin power connection.
Connect power to the power supply.
Do NOT connect ANYTHING else. Make sure you have the power connector on the CPU fan connected.
Use a small screwdriver to momentarily short the power switch connector on the motherboard. Consult your motherboard manual to find which two pins connect to your case's power switch. Then touch both pins with a screwdriver to complete the circuit and boot the system.

If all is well, it should power up and you should get a display. Then assemble the parts into the case and try again. If the system now fails to boot, you have a short in the case and need to recheck your motherboard standoffs.

If the system does not boot after this process, then you most likely have a faulty component. You'll need to swap parts, start with the power supply, until you determine what is defective.
See less See more
I sent an RMA request to Corsair and they'll replace it since it's still only two years old. I did the paperclip test on it, and the fan spun up, but I still can't get the graphics cards that use the 6 pin pci-e connectors to fully come on. Only the 7600 GT that doesn't need that connector works on it which is what led me to believe it was the PSU since I could boot into windows and everything fine with it and not the others, even though all the graphics cards worked with another PSU.

I'll let you know what happens tomorrow when I get the other PSU. Thank you for the advice, I appreciate it.
Please update when you get the new PSU installed.
Got it installed and it still does not display. So, I'm guessing it's the CMOS or mobo itself.

Aything else I can try? I sent an RMA request to Biostar, but I think I'm out of luck on that.
Do the bench test as Tyree suggested but at this point I would suspect the mobo especially if you are getting no beeps with the ram removed
Thanks, I just did the bench test and still nothing.

Guess it is the mobo, but it still works with the older 7600 gt.

Should I try and flash the bios or something now that i can see?

edit: nvm, now it's not even working with the 7600 gt
Sorry for the double post, don't see the edit button anymore.

I took the CMOS out, put in the old 7600 GT, took out one of my Ram sticks and it has booted to windows, but only after the cpu restarted itself a few times intermittently. I also switched the BIOS values to default.

edit: put other stick back in and it boots windows again. will try other graphics card and see what happens

edit again: put it the 8800 GT and it restarted intermittently again, and now wont display again.
1 - 8 of 8 Posts
Not open for further replies.