Tech Support banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hurray for years down the drain! My 4 year old maxtor 80 gig IDE has finally gone to that great motherboard in the sky. And what really stings is I had just bought an external HD to copy its files over (for some reason I had a 'sense' it was about to die...and its age of course...)

I'm kind of hoping to try and recover some data from it, but it doesn't look good, hell it looks worse then my last one dieing....

The setup is it was the slave on my primary IDE channel to my master drive (with windows and more important files). Today while starting up a program on the drive my computer shut down...coming back up to windows I heard a large pop sound, computer shut down again and restarted, this time...and here is my problem....NOT seeing the 2nd HD at all. (in the bios startup)

I've done data recovery before, hell this is about my 3rd HD to die (2 primarys before this 2ndary went out) but BIOs saw all those, even if it wouldn't boot to it.

So anyone have any idea if I might be able to get my computer to see this thing or am I screwed? Also, does anyone know if other types of HD are more reliable? I've heard SATAs are better but I see them die all the time as well in my work field, and with the heavy usage mine get I was very happy this one lasted as long as it did.

Also this hard drive died with very little warning, there was no 'clicks' before hand, no slowdowns, it worked beautifully, it passed all the tests on it, so having it fry so suddenly is very irritiating, are other types of drives at least better at giving warnings about their future death?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
UPdate

My hard drives back.....and my fans are going ape#$)(....everrest reports its operating at about 54 degrees....and my power supply fan is going nuts, ive opened the case up and laid it on its side hoping that cools it down some.

Is it possible the HD shut down due to heat and is back online now? I still plan to back it up asap though.

This has never happened before, i have no idea why it's so hot...it just turned winter here!
 

·
Registered
Joined
·
25,116 Posts
Dekent:

what gave it away was the "pop" !! its most likely a failing PSU

dont run your system any more until you get a high quality PSU like an Enermax or Antec / 550 watt is awesome >>>> too much doesnt hurt ~~ just extends the PSU's life span ~~ not enough juice and they burn up your system

WARNING stay clear of the generics / they arent worth the beautiful box they put them in !!!! the low price $35.00 is what draws people too them but in the end it will cost you more by replcaing burnt up componets and then you can buy the good PSU / a good psu is $100.00 any PSU for less than $85.00 is either too small or junk ??

look on newegg.com Antec tru power 550 has all the connections for just about any mobo

regards

joe
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top