Tech Support Forum banner

Get red LED on motherboard (Asus P8z77-v lx) after new RMA PSU

1599 Views 4 Replies 3 Participants Last post by  Tyree
I just got my new PSU from OCZ through an RMA, and I have done a breadboard build. I get a red LED on the memOk area of the motherboard, however I have tried both 2gb sticks of ram in each of the 4 RAM slots (A1,A2,B1,B2). Do I need to buy a new motherboard? I am leaning towards Gigabyte z77d3h because I want a board that is reliable over feature filled.
Not open for further replies.
1 - 2 of 5 Posts
OCZ PSU's are lower quality so the old one could have done some damage if it failed.
Remove all RAM, power on, listen for beep codes from the Mobo speaker. No RAM and no beeps indicates a Mobo problem.
If you need a new Mobo, Asus & Gigabyte are the better brand choices.
Note: the OS is tied to the present Mobo so replacing it will require a reinstall of the OS.
PC Specs?
Pre- Built Brand & Model Number
Custom Built- Brand & Model of Mobo-CPU-RAM-Graphics-PSU.
Any PC shop will have a Mobo speaker and the Mobo manual will have instructions and/or a pic of where it goes.
My assumption was this is a build that had worked previously and had a failed PSU replaced. :confused:
If it's a new build, Hyper X RAM is no stranger to compatibility problems.
What are the specs on the RAM?
1 - 2 of 5 Posts
Not open for further replies.