Tech Support Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Okay so here goes,

All my games used to run very smoothly even on 60fps till a couple of months back when every game I played below 144fps started to feel laggy/choppy. I tried every basic solution internet had to offer but had no luck with them.

My specs back then were:-
Acer 144hz monitor (no freesync or gsync)
GTX 1060 6gb
i5 8600k
8x2 3200mhz DDR4
Corsair HX750 PSU
Razer Viper wired with 1000hz polling rate

I was losing my mind over this issue until I recently decided to upgrade my monitor and GPU.
My specs now:-
Gigabyte g24f 165hz monitor (Gsync compatible)
RTX 3070 8gb
Everything else is the same.

I thought this upgrade would fix the issue but there's literally no difference. Any game that goes below 120-144 feels like I'm playing under 60fps whether it's single player or multiplayer. There is no stuttering or lag while using the pc for other purposes. The GPU temp barely every goes above 75° even at 100% usage and the CPU temp never goes above 60°

Here's a video benchmarking fps with afterburner: Youtube

Also, there's this thing called 99% fps on Nvidia geforce overlay which in my case is like half of my average fps.
Here's an example video: Youtube

What I have already tried:-

  • Clean reinstall of windows
  • Turning vsync on or off (I've never played any game with vsync on in my life)
  • Disabling fullscreen optimizations
  • Using both HDMI and DP cable
  • Using RTSS to cap FPS

This has been way too frustrating for me and i feel like i'm running out of options on the internet and at this point I'll take any help I can get. Please let me know if there's anything else i can provide you with to make you understand the issue better. Thanks
 
1 - 1 of 1 Posts
Top